summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWael M. Nasreddine2017-10-11 10:25:38 -0700
committerWael M. Nasreddine2017-10-11 10:25:38 -0700
commitdc312bc1db3c3f85cd35deed270b90a57e8f8bca (patch)
tree977627dfb569894949b386bded97ceb090fa5b49
downloadaur-dc312bc1db3c3f85cd35deed270b90a57e8f8bca.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d02a66db8cd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kovhernetes-git
+ pkgdesc = kOVHernetes (kovh) is a command-line utility for managing Kubernetes clusters on the OVH Cloud platform.
+ pkgver = r23.592a715
+ pkgrel = 1
+ url = https://github.com/antoineco/kOVHernetes
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = python-ovh
+ depends = python-cryptography
+ depends = python-docopt
+ depends = python-pyopenssl
+ provides = kovhernetes-git
+ conflicts = kovhernetes-git
+ source = git+https://github.com/antoineco/kOVHernetes.git
+ md5sums = SKIP
+
+pkgname = kovhernetes-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..92a90cfc4cab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar
+*~ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a3e7b89953b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Wael Nasreddine <wael.nasreddine@gmail.com>
+pkgname=kovhernetes-git
+_pkgname=kOVHernetes
+pkgver=0.0.1.dev0
+pkgrel=1
+pkgdesc="kOVHernetes (kovh) is a command-line utility for managing Kubernetes clusters on the OVH Cloud platform."
+arch=('any')
+url="https://github.com/antoineco/kOVHernetes"
+license=('Apache')
+depends=('python-ovh' 'python-cryptography' 'python-docopt' 'python-pyopenssl')
+makedepends=('git')
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+source=('git+https://github.com/antoineco/kOVHernetes.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}