summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 17:01:21 +0200
committersl1pkn072015-06-08 17:01:21 +0200
commitbc48c2920c8ddbd8fb016a92af7596c6d637148a (patch)
tree107d37f5fc012263d8aca02eedf8b102b11d06d5
downloadaur-bc48c2920c8ddbd8fb016a92af7596c6d637148a.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD35
-rw-r--r--kpar2.desktop.diff21
-rw-r--r--kpar2.install12
5 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6f2176cbc4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kpar2
+ pkgdesc = PAR2 verification and repair program for KDE4
+ pkgver = 0.4.5
+ pkgrel = 6
+ url = http://code.google.com/p/kpar2kde4/
+ install = kpar2.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = automoc4
+ depends = kdebase-runtime
+ depends = libpar2
+ source = http://kpar2kde4.googlecode.com/files/kpar2-0.4.5.tar.gz
+ source = kpar2.desktop.diff
+ sha1sums = e4dfbb55459452a17b0263bf3742acdb0e39d613
+ sha1sums = 0f3584e7fdc661f38ac36c6eeb4f249be4712c4a
+
+pkgname = kpar2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0398006d18f5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!kpar2.install
+!kpar2.desktop.diff
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..643fc9f6f95f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer; Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=kpar2
+pkgver=0.4.5
+pkgrel=6
+pkgdesc="PAR2 verification and repair program for KDE4"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/kpar2kde4/"
+license=('GPL3')
+depends=('kdebase-runtime' 'libpar2')
+makedepends=('cmake' 'automoc4')
+source=("http://kpar2kde4.googlecode.com/files/kpar2-${pkgver}.tar.gz"
+ 'kpar2.desktop.diff')
+sha1sums=('e4dfbb55459452a17b0263bf3742acdb0e39d613'
+ '0f3584e7fdc661f38ac36c6eeb4f249be4712c4a')
+install=kpar2.install
+
+prepare() {
+ mkdir -p build
+ patch -d "kpar2-${pkgver}" -p0 -i kpar2.desktop.diff
+}
+
+build() {
+ cd build
+ cmake "../kpar2-${pkgver}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/kpar2.desktop.diff b/kpar2.desktop.diff
new file mode 100644
index 000000000000..ac25c477c818
--- /dev/null
+++ b/kpar2.desktop.diff
@@ -0,0 +1,21 @@
+--- src/kpar2.desktop 2013-03-02 15:31:53.000000000 +0100
++++ src/kpar2.desktop.god 2013-10-18 19:57:36.000000000 +0200
+@@ -1,13 +1,12 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=KPar2
+-GenericName=A PAR2 verification and repair application
+-Exec=kpar2 %i %m -caption "%c"
++GenericName=KPar2
++Exec=kpar2 %i --miniicon -caption "%c"
+ Icon=kpar2
+ Type=Application
+ DocPath=kpar2/index.html
+ Comment=A PAR2 verification and repair application
+-MimeType=application/x-par2
+-Categories=Qt;KDE;Application;Utility;X-KDE-Utilities-File
++MimeType=application/x-par2;
++Categories=Qt;KDE;Utility;X-KDE-Utilities-File;
+ Terminal=false
+-MultipleArgs=false
++X-MultipleArgs=false
diff --git a/kpar2.install b/kpar2.install
new file mode 100644
index 000000000000..23f5838bced4
--- /dev/null
+++ b/kpar2.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}