summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-20 19:58:00 -0400
committerJean Lucas2019-08-20 19:58:00 -0400
commit8645e21261427df6c8e7df7dbf1be0e1ea44f089 (patch)
tree532ab0d6f88c5409e3231fab9a9ed29e95bcef58
parent8b095063022b7132ba7c0638c8cf73f19b6d644e (diff)
downloadaur-8645e21261427df6c8e7df7dbf1be0e1ea44f089.tar.gz
0.7.1
- Update deps and source naming schema - Disable building kmod - Fix build
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16402b6f0945..07eb0c547b19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = kpatch
pkgdesc = Live kernel patching
- pkgver = 0.6.3
- pkgrel = 3
+ pkgver = 0.7.1
+ pkgrel = 1
url = https://github.com/dynup/kpatch
arch = i686
arch = x86_64
license = GPL2
- makedepends = gcc
- depends = elfutils
- source = https://github.com/dynup/kpatch/archive/v0.6.3.tar.gz
- sha512sums = 0d266dd837ad651d7f46047cf2c8de527d08274a885a154c53354f4b3c5679d91c766d7d42294ffe71cc548e5ee865c7555f24001882b806f2fb48825f9b0c06
+ depends = bash
+ depends = libelf
+ source = kpatch-0.7.1.tar.gz::https://github.com/dynup/kpatch/archive/v0.7.1.tar.gz
+ sha512sums = c1b149e9532dc16ee4f7578aadf3eda73b53c889a055229490a7afd1fca8e6df755c98c938353f937b81679fe8d08e065c473a6c31e588b1eb67f2de56bfddea
pkgname = kpatch
diff --git a/PKGBUILD b/PKGBUILD
index 8cce2a3ce08c..c54b70e2e0b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,49 @@
# Maintainer: Jean Lucas <jean@4ray.co
pkgname=kpatch
-pkgver=0.6.3
-pkgrel=3
-pkgdesc="Live kernel patching"
+pkgver=0.7.1
+pkgrel=1
+pkgdesc='Live kernel patching'
arch=(i686 x86_64)
url=https://github.com/dynup/kpatch
license=(GPL2)
-depends=(elfutils)
-makedepends=(gcc)
-source=($url/archive/v$pkgver.tar.gz)
-sha512sums=('0d266dd837ad651d7f46047cf2c8de527d08274a885a154c53354f4b3c5679d91c766d7d42294ffe71cc548e5ee865c7555f24001882b806f2fb48825f9b0c06')
+depends=(bash libelf)
+source=(kpatch-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
+sha512sums=('c1b149e9532dc16ee4f7578aadf3eda73b53c889a055229490a7afd1fca8e6df755c98c938353f937b81679fe8d08e065c473a6c31e588b1eb67f2de56bfddea')
prepare() {
+ cd kpatch-$pkgver
+
# Fix search structure
- sed -i 's/libexec/lib/g' kpatch-$pkgver/kpatch-build/kpatch-build
+ sed -i 's#libexec#lib#g' kpatch-build/kpatch-build
+
+ # Linux 5.2 introduced API changes to the stack trace code
+ # The kmod core module hasn't been updated to support them, so it currently doesn't build
+ # It's functionality can however be provided by Linux's livepatch API
+ # See https://github.com/dynup/kpatch/issues/966
+ # Disable kmod for now
+ sed -i '3s#kmod ##' Makefile
}
build() {
cd kpatch-$pkgver
- make
+ make
}
package() {
cd kpatch-$pkgver
make DESTDIR="$pkgdir" install
- cd "$pkgdir"
-
# Remove incompatible init system file
+ cd "$pkgdir"
rm etc/init/kpatch.conf
rmdir -p etc/init
- cd usr
-
# Fix directory structure
+ cd usr
mv local/* .
rmdir local
- mv lib{exec/kpatch/*,/kpatch}
+ mv lib{exec,}/kpatch
mv {s,}bin/kpatch
- rmdir -p libexec/kpatch sbin
+ rmdir libexec sbin
}