summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-06-21 03:45:11 -0400
committerJean Lucas2019-06-21 03:45:11 -0400
commit8b095063022b7132ba7c0638c8cf73f19b6d644e (patch)
treeb09ae9b0f74197ca204fc8794496fa9d753ea89a
parent0b1d8b59b9f5210eb45822203eb6fdc812efec53 (diff)
downloadaur-8b095063022b7132ba7c0638c8cf73f19b6d644e.tar.gz
Switch to tagged versions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 927579fb6fc3..16402b6f0945 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = kpatch
pkgdesc = Live kernel patching
pkgver = 0.6.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dynup/kpatch
arch = i686
arch = x86_64
license = GPL2
makedepends = gcc
depends = elfutils
- source = https://github.com/dynup/kpatch/archive/f4ed9ff76997114ed838a3b964508d721f19f293.tar.gz
- sha512sums = a51f46f4c34b1f2322a5e22349684f5c90bb5d7eb5f173d636ef649d4159ff68697773dfdb977d54506b67294bdea1ea0df6a45947c7c2e82d7f130a366269f7
+ source = https://github.com/dynup/kpatch/archive/v0.6.3.tar.gz
+ sha512sums = 0d266dd837ad651d7f46047cf2c8de527d08274a885a154c53354f4b3c5679d91c766d7d42294ffe71cc548e5ee865c7555f24001882b806f2fb48825f9b0c06
pkgname = kpatch
diff --git a/PKGBUILD b/PKGBUILD
index fa39ef7c2eb2..8cce2a3ce08c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,28 @@
pkgname=kpatch
pkgver=0.6.3
-_commit=f4ed9ff76997114ed838a3b964508d721f19f293
-pkgrel=2
+pkgrel=3
pkgdesc="Live kernel patching"
arch=(i686 x86_64)
url=https://github.com/dynup/kpatch
license=(GPL2)
depends=(elfutils)
makedepends=(gcc)
-source=($url/archive/$_commit.tar.gz)
-sha512sums=('a51f46f4c34b1f2322a5e22349684f5c90bb5d7eb5f173d636ef649d4159ff68697773dfdb977d54506b67294bdea1ea0df6a45947c7c2e82d7f130a366269f7')
+source=($url/archive/v$pkgver.tar.gz)
+sha512sums=('0d266dd837ad651d7f46047cf2c8de527d08274a885a154c53354f4b3c5679d91c766d7d42294ffe71cc548e5ee865c7555f24001882b806f2fb48825f9b0c06')
prepare() {
# Fix search structure
- sed -i 's/libexec/lib/g' kpatch-$_commit/kpatch-build/kpatch-build
+ sed -i 's/libexec/lib/g' kpatch-$pkgver/kpatch-build/kpatch-build
}
build() {
- cd kpatch-$_commit
+ cd kpatch-$pkgver
make
}
package() {
- cd kpatch-$_commit
+ cd kpatch-$pkgver
make DESTDIR="$pkgdir" install
cd "$pkgdir"