summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-20 20:13:37 -0400
committerJean Lucas2019-08-20 20:13:37 -0400
commite972c0f73a71d6d1372fa9c594aae9e2d4041307 (patch)
treeaa0591160c6ad81defdbeb04276c78b9dcde7a70
parent8645e21261427df6c8e7df7dbf1be0e1ea44f089 (diff)
downloadaur-e972c0f73a71d6d1372fa9c594aae9e2d4041307.tar.gz
Fix systemd service file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07eb0c547b19..27e261a9b3e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kpatch
pkgdesc = Live kernel patching
pkgver = 0.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dynup/kpatch
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c54b70e2e0b9..d775b80b36e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=kpatch
pkgver=0.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='Live kernel patching'
arch=(i686 x86_64)
url=https://github.com/dynup/kpatch
@@ -34,16 +34,21 @@ package() {
cd kpatch-$pkgver
make DESTDIR="$pkgdir" install
- # Remove incompatible init system file
cd "$pkgdir"
+
+ # Remove incompatible init system file
rm etc/init/kpatch.conf
rmdir -p etc/init
- # Fix directory structure
cd usr
+
+ # Fix directory structure
mv local/* .
rmdir local
mv lib{exec,}/kpatch
mv {s,}bin/kpatch
rmdir libexec sbin
+
+ # Fix file path in systemd service file
+ sed -i 's#local/s##' lib/systemd/system/kpatch.service
}