summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2024-01-09 16:01:19 +0800
committertaotieren2024-01-09 16:01:19 +0800
commit717ca20b88c0ccea923da5e390cefba910d50406 (patch)
treeb5d392673856e6c75ff710b66d5c0eaf24784dfc
parent36998e8933d2f331b7fb882967e40e9e335068e6 (diff)
downloadaur-717ca20b88c0ccea923da5e390cefba910d50406.tar.gz
[lilac] updated to 0.9.9.r7.g8513926-2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD39
2 files changed, 20 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b05c5cee9235..abb3dd758f1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kpatch-git
pkgdesc = Live kernel patching (git)
- pkgver = 0.7.1+r40+g6f5edcd
- pkgrel = 1
+ pkgver = 0.9.9.r7.g8513926
+ pkgrel = 2
url = https://github.com/dynup/kpatch
arch = i686
arch = x86_64
@@ -11,8 +11,7 @@ pkgbase = kpatch-git
depends = libelf
provides = kpatch
conflicts = kpatch
- source = git+https://github.com/dynup/kpatch
+ source = kpatch-git::git+https://github.com/dynup/kpatch.git
sha512sums = SKIP
pkgname = kpatch-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 70856da5e6b0..9c61b294342f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Jean Lucas <jean@4ray.co>
+# Maintainer: taotieren <admin@taotieren.com>
# Contributor: Quey-Liang Kao <s101062801@m101.nthu.edu.tw>
pkgname=kpatch-git
-pkgver=0.7.1+r40+g6f5edcd
-pkgrel=1
+pkgver=0.9.9.r7.g8513926
+pkgrel=2
pkgdesc='Live kernel patching (git)'
arch=(i686 x86_64)
url=https://github.com/dynup/kpatch
@@ -12,20 +13,26 @@ depends=(bash libelf)
makedepends=(git)
provides=(kpatch)
conflicts=(kpatch)
-source=(git+$url)
+source=("${pkgname}::git+$url.git")
sha512sums=('SKIP')
pkgver() {
- cd kpatch
- git describe --tags | sed 's#v##;s#-#+#g;s#+#+r#'
+ cd "${srcdir}/${pkgname}/"
+ git describe --long --tags | sed 's/^v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd kpatch
+ cd "${srcdir}/${pkgname}/"
# Fix search structure
sed -i 's#libexec#lib#g' kpatch-build/kpatch-build
+ # Change default bindir
+ sed -i 's#SBIN#BIN#g' kpatch/Makefile
+
+ # Fix file path in systemd service file
+ sed -i 's#sbin#bin#' contrib/kpatch.service
+
# Linux 5.2 introduced API changes to the stack trace code
# The kmod core module hasn't been updated to support them, so it currently doesn't build
# It's functionality can however be provided by Linux's livepatch API
@@ -35,29 +42,17 @@ prepare() {
}
build() {
- cd kpatch
- make
+ cd "${srcdir}/${pkgname}/"
+ make PREFIX=/usr
}
package() {
- cd kpatch
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}/"
+ make PREFIX=/usr LIBEXEC=lib DESTDIR="$pkgdir" install
cd "$pkgdir"
# Remove incompatible init system file
rm etc/init/kpatch.conf
rmdir -p etc/init
-
- cd usr
-
- # Fix directory structure
- mv local/* .
- rmdir local
- mv lib{exec,}/kpatch
- mv {s,}bin/kpatch
- rmdir libexec sbin
-
- # Fix file path in systemd service file
- sed -i 's#local/s##' lib/systemd/system/kpatch.service
}