summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 22:46:49 +0200
committerAntonio Rojas2015-06-08 22:46:49 +0200
commit1d770c7e03ec9cef5a988437348c6cc8149a5220 (patch)
treeb7ba3442a1239766f6054d4256b7404b9559c5ed
downloadaur-1d770c7e03ec9cef5a988437348c6cc8149a5220.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf0c2e05e494
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kpeople-git
+ pkgdesc = A library that provides access to all contacts and the people who hold them
+ pkgver = r991.77a5fab
+ pkgrel = 1
+ url = http://community.kde.org/KTp/libkpeople
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules-git
+ makedepends = git
+ makedepends = python
+ depends = kwidgetsaddons-git
+ depends = kitemviews-git
+ provides = kpeople
+ conflicts = kpeople
+ source = git://anongit.kde.org/kpeople.git
+ sha256sums = SKIP
+
+pkgname = kpeople-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37d2a3452c57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Antonio Rojas
+
+pkgname=kpeople-git
+pkgver=r991.77a5fab
+pkgrel=1
+pkgdesc='A library that provides access to all contacts and the people who hold them'
+arch=(i686 x86_64)
+url='http://community.kde.org/KTp/libkpeople'
+license=(LGPL)
+depends=(kwidgetsaddons-git kitemviews-git)
+makedepends=(extra-cmake-modules-git git python)
+conflicts=(kpeople)
+provides=(kpeople)
+source=("git://anongit.kde.org/kpeople.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd kpeople
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kpeople \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}