summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent2016-09-23 00:22:58 +0200
committerVincent2016-09-23 00:22:58 +0200
commit2864101a10fb78c5003d4d55e9d5574620c67c17 (patch)
tree57c4416c8e2ea2389fc57e4a79ce2eb7d7701eb4
downloadaur-2864101a10fb78c5003d4d55e9d5574620c67c17.tar.gz
creating the package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--makefile_linux.patch29
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d06651a55c9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kplot
+ pkgdesc = Cairo plotting library
+ pkgver = 0.1.14
+ pkgrel = 1
+ url = https://kristaps.bsd.lv/kplot/
+ arch = i686
+ arch = x86_64
+ license = ISC
+ depends = cairo libbsd
+ source = https://kristaps.bsd.lv/kplot/snapshots/kplot.tgz
+ source = makefile_linux.patch
+ sha1sums = cc3ab77a39f5d1d057f8ed5319b3e1f52c4e9343
+ sha1sums = 115e6a685440d14efd682ac6a5418b1cb8204099
+
+pkgname = kplot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fe66c579aea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Vincent Hourdin <vh|at|free-astro=DOT=vinvin.tf>
+pkgname=kplot
+pkgver=0.1.14
+pkgrel=1
+pkgdesc="Cairo plotting library"
+arch=('i686' 'x86_64')
+license=('ISC')
+depends=('cairo libbsd')
+url="https://kristaps.bsd.lv/kplot/"
+
+_pkgname="${pkgname}-${pkgver}"
+source=("https://kristaps.bsd.lv/kplot/snapshots/kplot.tgz" "makefile_linux.patch")
+sha1sums=('cc3ab77a39f5d1d057f8ed5319b3e1f52c4e9343' '115e6a685440d14efd682ac6a5418b1cb8204099')
+
+prepare() {
+ cd "${_pkgname}"
+ patch -p1 < ../makefile_linux.patch
+}
+
+build() {
+ cd "${_pkgname}"
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make PREFIX="/usr" DESTDIR="${pkgdir}" install
+}
+
diff --git a/makefile_linux.patch b/makefile_linux.patch
new file mode 100644
index 000000000000..10aee3cde96d
--- /dev/null
+++ b/makefile_linux.patch
@@ -0,0 +1,29 @@
+diff -Nu kplot-0.1.14.orig/Makefile kplot-0.1.14/Makefile
+--- kplot-0.1.14.orig/Makefile 2016-03-04 01:26:42.000000000 +0100
++++ kplot-0.1.14/Makefile 2016-09-23 00:17:33.609399803 +0200
+@@ -6,7 +6,7 @@
+ VERSION = 0.1.14
+ LDADD = `pkg-config --libs --silence-errors cairo || echo '-L/opt/X11/lib -lcairo'`
+ #If you're on GNU/Linux, you'll need to uncomment this.
+-#LDADD += -L/usr/local/include -lbsd
++LDADD += -L/usr/local/include -lbsd
+ VERSIONS = version_0_1_4.xml \
+ version_0_1_5.xml \
+ version_0_1_6.xml \
+@@ -100,7 +100,7 @@
+ stddev.o \
+ tic.o \
+ vector.o
+-PREFIX = /usr/local
++PREFIX = /usr
+ HTMLS = index.html \
+ man/kdata_array_alloc.3.html \
+ man/kdata_array_fill.3.html \
+@@ -181,7 +181,7 @@
+ mkdir -p $(DESTDIR)$(PREFIX)/share/man/man3
+ install -m 0444 libkplot.a $(DESTDIR)$(PREFIX)/lib
+ install -m 0444 kplot.h $(DESTDIR)$(PREFIX)/include
+- install -m 0444 $(MANS) $(DESTDIR)$(PREFIX)/man/man3
++ install -m 0444 $(MANS) $(DESTDIR)$(PREFIX)/share/man/man3
+
+ www: $(HTMLS) $(PNGS) kplot.tgz kplot.tgz.sha512