summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-12 22:17:44 +0200
committersl1pkn072015-06-12 22:17:44 +0200
commit9da37898331a7890aa030aa754096c11558239e2 (patch)
tree4e78b7eb023aceddd76ea87229b009ab4a562763
downloadaur-9da37898331a7890aa030aa754096c11558239e2.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e546807ae146
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kpmcore-git
+ pkgdesc = Library for managing partitions. Common code for KDE Partition Manager and other projects.
+ pkgver = 1.2.1.r11.5c04c17
+ pkgrel = 1
+ url = http://kde.org/applications/system/kdepartitionmanager/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = git
+ makedepends = python
+ depends = parted
+ depends = kio
+ provides = kpmcore
+ conflicts = kmpcore
+ conflicts = kpmcore
+ source = git://anongit.kde.org/kpmcore.git
+ sha1sums = SKIP
+
+pkgname = kpmcore-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b858439cf869
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=kpmcore-git
+pkgver=1.2.1.r11.5c04c17
+pkgrel=1
+pkgdesc="Library for managing partitions. Common code for KDE Partition Manager and other projects."
+arch=('i686' 'x86_64')
+url='http://kde.org/applications/system/kdepartitionmanager/'
+license=('GPL2')
+depends=('parted' 'kio')
+conflicts=('kmpcore' 'kpmcore')
+provides=('kpmcore')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
+source=('git://anongit.kde.org/kpmcore.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd kpmcore
+ _ver="$(cat CMakeLists.txt | grep -m3 -e VERSION_MAJOR -e VERSION_MINOR -e VERSION_RELEASE | grep -o "[[:digit:]]*" | xargs)"
+ echo -e "${_ver// /.}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kpmcore \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}