summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-04-03 02:24:45 +0200
committerml2020-04-03 02:24:45 +0200
commit2dcc448b8d6ae667eebba99b86fd85c9860471e7 (patch)
tree34b35503ab156e66313b674d73f386a1d73524cf
downloadaur-2dcc448b8d6ae667eebba99b86fd85c9860471e7.tar.gz
newpkg: kpt 0.17.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
-rw-r--r--kpt.install4
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99fc247c1a50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kpt
+ pkgdesc = Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations
+ pkgver = 0.17.0
+ pkgrel = 1
+ url = https://googlecontainertools.github.io/kpt/
+ install = kpt.install
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ depends = git
+ source = kpt-0.17.0.tar.gz::https://github.com/GoogleContainerTools/kpt/archive/v0.17.0.tar.gz
+ sha256sums = 460f54e3d0cff3ae5edf9f1bf5268d219c44c7c01d0ddf9e1d6f33f0ab01ddb8
+
+pkgname = kpt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..541c436bb0a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ml <ml@visu.li>
+pkgname=kpt
+pkgver=0.17.0
+pkgrel=1
+pkgdesc='Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations'
+arch=('x86_64')
+url='https://googlecontainertools.github.io/kpt/'
+license=('Apache')
+depends=('git')
+makedepends=('go')
+install=kpt.install
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/GoogleContainerTools/kpt/archive/v${pkgver}.tar.gz")
+sha256sums=('460f54e3d0cff3ae5edf9f1bf5268d219c44c7c01d0ddf9e1d6f33f0ab01ddb8')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS='-buildmode=pie -modcacherw -trimpath'
+ go build -o "$pkgname"
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ # tests rely on git identity being present. fails in clean chroot env
+ #go test ./...
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "$pkgname" -t "${pkgdir}/usr/bin"
+}
diff --git a/kpt.install b/kpt.install
new file mode 100644
index 000000000000..6c2d6af3c32e
--- /dev/null
+++ b/kpt.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Run 'kpt --install-completion' to install bash completions"
+ echo 'WARNING: This will modify your ~/.bashrc'
+}