summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-12-18 10:30:04 +0100
committerml2020-12-18 10:30:20 +0100
commitc094eaa5062d86f208978c0dbebc25dd0e472ef5 (patch)
tree5df6c2b2b4c7eb5811266fc7037b6991a3e2f95f
parentab99745580e320d15e9cefaf0b39c3f1bef058f7 (diff)
downloadaur-c094eaa5062d86f208978c0dbebc25dd0e472ef5.tar.gz
updpkg: kpt 0.37.0-2
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD15
3 files changed, 3 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6af2bcbe45cd..47f3f9cd3161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kpt
pkgdesc = Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations
pkgver = 0.37.0
- pkgrel = 1
+ pkgrel = 2
url = https://googlecontainertools.github.io/kpt/
install = kpt.install
arch = x86_64
diff --git a/.gitignore b/.gitignore
index f1ecb611e6e2..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1 @@
-/pkg/
-/src/
-/*.log
-/*.tar.gz
-/*.pkg.tar*
-/*.src.tar*
+*
diff --git a/PKGBUILD b/PKGBUILD
index 9c79470d88bf..111d994f2ae4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <>
pkgname=kpt
pkgver=0.37.0
-pkgrel=1
+pkgrel=2
pkgdesc='Toolkit to manage, manipulate, customize, and apply Kubernetes Resource configurations'
arch=('x86_64')
url='https://googlecontainertools.github.io/kpt/'
@@ -13,11 +13,6 @@ install=kpt.install
source=("https://github.com/GoogleContainerTools/kpt/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('1452b7b287749728f17040c27e5054a80ad40443725097516be5bf31c6d3bd60')
-prepare() {
- cd "${pkgname}-${pkgver}"
- go mod download
-}
-
build() {
cd "${pkgname}-${pkgver}"
export CGO_ENABLED=1
@@ -29,14 +24,6 @@ build() {
go build -o "$pkgname" -ldflags=-linkmode=external
}
-# tests require configures Git identities
-# @TODO find safe way to set Git identities without violating $HOME privacy
-#check() {
-# cd "${pkgname}-${pkgver}"
-# # ./internal only. we don't want e2e tests
-# go test -short ./internal/...
-#}
-
package() {
cd "${pkgname}-${pkgver}"
install -Dm755 "$pkgname" -t "${pkgdir}/usr/bin"