summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2022-02-12 12:29:21 -0700
committergustawho2022-02-12 12:29:21 -0700
commit81abe1b0db684af44c0afa1cea8d9f8e8c95b0fa (patch)
tree069cb2c8eeaebe300914f6e3a12441fb94df8936
downloadaur-81abe1b0db684af44c0afa1cea8d9f8e8c95b0fa.tar.gz
Package created
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c69c21c8631
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kquickchatcomponents-git
+ pkgdesc = Set of chat components for QtQuick chat apps wishing to fit in with KDE's collection of chat apps
+ pkgver = r15.f184bbc
+ pkgrel = 1
+ url = https://invent.kde.org/libraries/kquickchatcomponents
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = extra-cmake-modules
+ depends = qt5-base
+ depends = qt5-declarative
+ provides = kquickimageeditor
+ conflicts = kquickimageeditor
+ source = git+https://invent.kde.org/libraries/kquickchatcomponents.git
+ sha256sums = SKIP
+
+pkgname = kquickchatcomponents-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e96f48e3f84e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
+pkgname=kquickchatcomponents-git
+pkgver=r15.f184bbc
+pkgrel=1
+pkgdesc="Set of chat components for QtQuick chat apps wishing to fit in with KDE's collection of chat apps"
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="https://invent.kde.org/libraries/kquickchatcomponents"
+license=('GPL3')
+depends=('qt5-base' 'qt5-declarative')
+makedepends=('git' 'extra-cmake-modules')
+provides=('kquickimageeditor')
+conflicts=('kquickimageeditor')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+}