summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin King2018-04-03 20:38:06 -0500
committerKevin King2018-04-03 20:38:33 -0500
commit05ab8ecfdc5450ddd111a141896566fa8efaeaae (patch)
treed3db290979fff2a593c0901ded470118a29a35d8
parent8e9d3a0697fdda9335144b033d3e9f8124467014 (diff)
downloadaur-05ab8ecfdc5450ddd111a141896566fa8efaeaae.tar.gz
Install cargo-web in debug to save compilation time
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d909b3ebdec..9230e7c8f01a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,8 @@ prepare() {
# ensure a toolchain is selected if rustup was used to install rust
(which rustup 2>/dev/null && (rustup which cargo || rustup default stable)) || true
rustup target add wasm32-unknown-emscripten
- cargo install cargo-web 2>/dev/null || true
+ # cargo web 0.6.9 required to build dashboard frontend
+ cargo install --debug --version 0.6.9 cargo-web 2>/dev/null || true
cargo web --version
mkdir -p "${srcdir}/src/github.com/kryptco/"
rm -rf "${srcdir}/src/github.com/kryptco/kr"