summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo2017-05-05 10:51:06 +0200
committerDanilo2017-05-05 10:51:23 +0200
commitd8ff029a622f0372c959bbec1736b85e21b6ee16 (patch)
treece077553f8c765e59392b8704ec1790eef5e9556
downloadaur-d8ff029a622f0372c959bbec1736b85e21b6ee16.tar.gz
Initial version
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD51
-rw-r--r--kr.install7
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d4fcf055cb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri May 5 08:51:19 UTC 2017
+pkgbase = kr-git
+ pkgdesc = SSH using a key stored in Kryptonite
+ pkgver = r494.f3b43c9
+ pkgrel = 1
+ url = https://github.com/kryptco/kr
+ install = kr.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = rust
+ makedepends = cargo
+ makedepends = go
+ provides = kr
+ conflicts = kr
+ source = git+https://github.com/kryptco/kr
+ md5sums = SKIP
+
+pkgname = kr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3579c217ea8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.swp
+*.tar.xz
+pkg/
+src/
+kr/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab84b466e09e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Danilo <aur ät dbrgn döt ch>
+pkgname=kr-git
+pkgver=r494.f3b43c9
+pkgrel=1
+pkgdesc="SSH using a key stored in Kryptonite"
+arch=('i686' 'x86_64')
+url="https://github.com/kryptco/kr"
+license=('custom')
+groups=()
+depends=()
+makedepends=('rust' 'cargo' 'go')
+checkdepends=()
+optdepends=()
+provides=('kr')
+conflicts=('kr')
+backup=()
+options=()
+install=kr.install
+changelog=
+source=("git+https://github.com/kryptco/kr")
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd ${srcdir}/src/github.com/kryptco/kr
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p "${srcdir}/src/github.com/kryptco/"
+ rm -rf "${srcdir}/src/github.com/kryptco/kr"
+ mv "${srcdir}/kr" "${srcdir}/src/github.com/kryptco/kr"
+}
+
+build() {
+ cd "${srcdir}/src/github.com/kryptco/kr"
+ GOPATH=${srcdir} make
+}
+
+check() {
+ cd "${srcdir}/src/github.com/kryptco/kr"
+ GOPATH=${srcdir} make check
+}
+
+package() {
+ cd "${srcdir}/src/github.com/kryptco/kr"
+ install -D -m 755 "bin/kr" "${pkgdir}/usr/bin/kr"
+ install -D -m 755 "bin/krd" "${pkgdir}/usr/bin/krd"
+ install -D -m 755 "bin/krssh" "${pkgdir}/usr/bin/krssh"
+ install -D -m 755 "bin/kr-pkcs11.so" "${pkgdir}/usr/lib/kr-pkcs11.so"
+}
diff --git a/kr.install b/kr.install
new file mode 100644
index 000000000000..132fff255acf
--- /dev/null
+++ b/kr.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo -e "\e[32m\e[1m============================\e[0m"
+ echo -e "\e[32mTo enable SSH through kr, please run the following command:\e[0m"
+ echo -e "\e[94m"
+ echo "echo -e '\\n# Added by Kryptonite\\nHost *\\n\\tPKCS11Provider /usr/lib/kr-pkcs11.so\\n\\tProxyCommand /usr/bin/krssh %h %p\\n\\tIdentityFile ~/.ssh/id_kryptonite\\n\\tIdentityFile ~/.ssh/id_ed25519\\n\\tIdentityFile ~/.ssh/id_rsa\\n\\tIdentityFile ~/.ssh/id_ecdsa\\n\\tIdentityFile ~/.ssh/id_dsa' >> ~/.ssh/config"
+ echo -e "\e[0m\e[32m\e[1m============================\e[0m"
+}