summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Jaksch2016-08-23 10:17:50 +0200
committerOliver Jaksch2016-08-23 10:17:50 +0200
commitd7ac29576139da2981ae6d7a87cbc552fbfbfff3 (patch)
tree80db72443d33c4fa136d7537f218294b48f439dd
downloadaur-d7ac29576139da2981ae6d7a87cbc552fbfbfff3.tar.gz
Initial commit - taken from https://github.com/aur-archive/kradio
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
-rw-r--r--kradio.install11
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bdbfd5cbe39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Aug 23 08:17:39 UTC 2016
+pkgbase = kradio
+ pkgdesc = Comfortable KDE internet and AM/FM radio application
+ pkgver = 4.0.8
+ pkgrel = 1
+ url = http://kradio.sourceforge.net/
+ install = kradio.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = automoc4
+ makedepends = cmake
+ makedepends = boost
+ depends = kdebase-runtime
+ depends = lirc-utils
+ depends = libmms
+ depends = ffmpeg
+ source = http://downloads.sourceforge.net/kradio/kradio4-4.0.8.tar.bz2
+ sha256sums = b6a0354ee0d8a69700b95428cf305940d00ff67c1a3268e8fdd9852bbacc000e
+
+pkgname = kradio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26387b3ce16c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Oliver Jaksch <arch-aur@com-in.de>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# https://github.com/aur-archive/kradio
+
+pkgname=kradio
+pkgver=4.0.8
+pkgrel=1
+pkgdesc='Comfortable KDE internet and AM/FM radio application'
+arch=('i686' 'x86_64')
+url='http://kradio.sourceforge.net/'
+license=('GPL2')
+depends=('kdebase-runtime' 'lirc-utils' 'libmms' 'ffmpeg')
+makedepends=('automoc4' 'cmake' 'boost')
+install="${pkgname}.install"
+source=("http://downloads.sourceforge.net/${pkgname}/kradio4-${pkgver}.tar.bz2")
+sha256sums=('b6a0354ee0d8a69700b95428cf305940d00ff67c1a3268e8fdd9852bbacc000e')
+
+build() {
+ cd "${srcdir}"
+ mkdir build
+ cd build
+ cmake "../${pkgname}4-${pkgver}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make ${MAKEFLAGS}
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/kradio.install b/kradio.install
new file mode 100644
index 000000000000..97fda5a9615b
--- /dev/null
+++ b/kradio.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}