summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2019-12-19 20:23:25 +0100
committerThomas Weißschuh2019-12-19 20:23:25 +0100
commit07636cb970452f1cea214fa8e60b442e53775c75 (patch)
tree9da19b1a2794f247cf9f3405dbb5d9febce3431c
parent723ebad2dc295c596f5e6c290bb936ea2dc574b4 (diff)
downloadaur-07636cb970452f1cea214fa8e60b442e53775c75.tar.gz
upgpkg: kraft 0.90-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-build-with-Qt-5.12-Strange-include-QtSql-problem.patch67
-rw-r--r--0002-Disalbe-nullptr-compiler-warning-which-shadows-real-.patch26
-rw-r--r--PKGBUILD13
4 files changed, 8 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36d6082b017d..c1d751ec49c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kraft
pkgdesc = A program suitable for all trades or crafts
- pkgver = 0.82
- pkgrel = 2
+ pkgver = 0.90
+ pkgrel = 1
url = http://www.volle-kraft-voraus.de/
arch = i686
arch = x86_64
@@ -13,12 +13,8 @@ pkgbase = kraft
depends = ctemplate
depends = python2-reportlab
depends = python2-pypdf2
- source = https://github.com/dragotin/kraft/archive/v0.82.tar.gz
- source = 0001-Fix-build-with-Qt-5.12-Strange-include-QtSql-problem.patch
- source = 0002-Disalbe-nullptr-compiler-warning-which-shadows-real-.patch
- sha256sums = 85d467118fcf2fe1d4fe171e2de759d4c7d70cf054f646676eb6d703f0fade48
- sha256sums = 16b58ae1a839d35063a79938969f5a70e360bea362ae7275b5ae045fc3c47373
- sha256sums = 91de8820cefc19230d67009c01157c4e23ee17ad856c280c7244822f151d5c9c
+ source = https://github.com/dragotin/kraft/archive/v0.90.tar.gz
+ sha256sums = 53d8e1afd6a0e9554a5bde44b654c11130f9ac43327759772351710ae1cb6f6b
pkgname = kraft
diff --git a/0001-Fix-build-with-Qt-5.12-Strange-include-QtSql-problem.patch b/0001-Fix-build-with-Qt-5.12-Strange-include-QtSql-problem.patch
deleted file mode 100644
index 17f71674c7be..000000000000
--- a/0001-Fix-build-with-Qt-5.12-Strange-include-QtSql-problem.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 3ac6fb9e8eeea7a67c9c3b37f9fa4e32c1fee513 Mon Sep 17 00:00:00 2001
-From: Klaas Freitag <freitag@opensuse.org>
-Date: Wed, 26 Dec 2018 22:04:12 +0100
-Subject: [PATCH 1/6] Fix build with Qt 5.12: Strange include<QtSql> problem
- that breaks.
-
-Workaround: Use specific includes for Sql classes rather than QtSql.
----
- src/catalogchapter.cpp | 2 +-
- src/defaultprovider.cpp | 7 ++++++-
- src/templkataloglistview.cpp | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/src/catalogchapter.cpp b/src/catalogchapter.cpp
-index 0724cdd..a35d7ff 100644
---- a/src/catalogchapter.cpp
-+++ b/src/catalogchapter.cpp
-@@ -17,7 +17,7 @@
-
- #include <QtCore>
- #include <QtGui>
--#include <QtSql>
-+#include <QSqlQuery>
-
- #include <QDebug>
-
-diff --git a/src/defaultprovider.cpp b/src/defaultprovider.cpp
-index 55f6ba7..b253ef9 100644
---- a/src/defaultprovider.cpp
-+++ b/src/defaultprovider.cpp
-@@ -14,7 +14,10 @@
- * (at your option) any later version. *
- * *
- ***************************************************************************/
--#include <QtSql>
-+#include <QSqlQuery>
-+#include <QSqlTableModel>
-+#include <QSqlRecord>
-+
- #include <QFile>
- #include <QTextStream>
- #include <QDebug>
-@@ -24,6 +27,8 @@
- #include "doctext.h"
- #include "kraftsettings.h"
- #include "doctype.h"
-+#include "kraftdoc.h"
-+#include "dbids.h"
-
- #include <klocalizedstring.h>
-
-diff --git a/src/templkataloglistview.cpp b/src/templkataloglistview.cpp
-index 9c4eaeb..6a3d52a 100644
---- a/src/templkataloglistview.cpp
-+++ b/src/templkataloglistview.cpp
-@@ -16,7 +16,7 @@
- * *
- ***************************************************************************/
-
--#include <QtSql>
-+#include <QSqlQuery>
- #include <QDebug>
- #include <QMenu>
-
---
-2.20.1
-
diff --git a/0002-Disalbe-nullptr-compiler-warning-which-shadows-real-.patch b/0002-Disalbe-nullptr-compiler-warning-which-shadows-real-.patch
deleted file mode 100644
index 27bf3e568dc9..000000000000
--- a/0002-Disalbe-nullptr-compiler-warning-which-shadows-real-.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 20984ac45fa2026bb8f6f463bf194f1d83f9564a Mon Sep 17 00:00:00 2001
-From: Klaas Freitag <freitag@opensuse.org>
-Date: Wed, 26 Dec 2018 22:07:20 +0100
-Subject: [PATCH 2/6] Disalbe nullptr compiler warning which shadows real
- warnings for now.
-
----
- CMakeLists.txt | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7cf3879..5db1908 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -64,6 +64,8 @@ find_package(Ctemplate REQUIRED)
-
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-suggest-override")
- #option(QTINDICATE_DISABLE "Disable support for notifications via indicator")
-+# disable the warning about null-pointer zero. FIXME.
-+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-zero-as-null-pointer-constant")
-
- add_definitions(${QT_DEFINITIONS} )
-
---
-2.20.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 400481e32aef..c686cad4d954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,15 @@
# Contributor: shamrok <szamrok@gmail.com>
pkgname=kraft
-pkgver=0.82
-pkgrel=2
+pkgver=0.90
+pkgrel=1
pkgdesc="A program suitable for all trades or crafts"
arch=('i686' 'x86_64')
url="http://www.volle-kraft-voraus.de/"
license=('GPL')
depends=('boost' 'akonadi-contacts' 'ctemplate' 'python2-reportlab' 'python2-pypdf2')
makedepends=('cmake' 'extra-cmake-modules')
-source=("https://github.com/dragotin/kraft/archive/v${pkgver}.tar.gz"
- '0001-Fix-build-with-Qt-5.12-Strange-include-QtSql-problem.patch'
- '0002-Disalbe-nullptr-compiler-warning-which-shadows-real-.patch'
-)
+source=("https://github.com/dragotin/kraft/archive/v${pkgver}.tar.gz")
prepare() {
@@ -48,6 +45,4 @@ package() {
make "DESTDIR=${pkgdir}" install
}
-sha256sums=('85d467118fcf2fe1d4fe171e2de759d4c7d70cf054f646676eb6d703f0fade48'
- '16b58ae1a839d35063a79938969f5a70e360bea362ae7275b5ae045fc3c47373'
- '91de8820cefc19230d67009c01157c4e23ee17ad856c280c7244822f151d5c9c')
+sha256sums=('53d8e1afd6a0e9554a5bde44b654c11130f9ac43327759772351710ae1cb6f6b')