summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUnikraft Bot2023-08-25 15:55:42 +0000
committerUnikraft Bot2023-08-25 15:55:42 +0000
commit6fbfb73f2714deef6db0706a3d36aec77770ef98 (patch)
treed09ddc9cca09053a158330cda558f1e1a90caf79
parent1bf318f37bd1ed4683809bd539eeefff2e0328de (diff)
downloadaur-6fbfb73f2714deef6db0706a3d36aec77770ef98.tar.gz
Update to v0.6.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8e549a5ff30..0086982586d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = kraftkit-bin
pkgdesc = Build and use highly customized and ultra-lightweight unikernels
- pkgver = 0.6.4
+ pkgver = 0.6.5
pkgrel = 1
url = https://kraftkit.sh
license = BSD-3-Clause
conflicts = kraftkit
provides = kraftkit
+ arch = aarch64
+ source_aarch64 = https://github.com/unikraft/kraftkit/releases/download/v0.6.5/kraftkit_0.6.5_linux_arm64.tar.gz
+ sha256sums_aarch64 = 24092adcd0c52706617e3b60e83114a05d65b91c8aed1332c0a529ab4a2d2e1e
arch = x86_64
- source_x86_64 = https://github.com/unikraft/kraftkit/releases/download/v0.6.4/kraftkit_0.6.4_linux_amd64.tar.gz
- sha256sums_x86_64 = 4ddfddced7457650f24e04509b492eaa63b5e6cdbef75aff2552d4704f66fec9
+ source_x86_64 = https://github.com/unikraft/kraftkit/releases/download/v0.6.5/kraftkit_0.6.5_linux_amd64.tar.gz
+ sha256sums_x86_64 = 7a0192ba59d3341887ced747abed24dfea92fb982f0103e58a2ea8d3e8f71401
pkgname = kraftkit-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5625a1d4ba05..2684c9f82e9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,20 @@
# Maintainer: Alexander Jung <alex at unikraft dot io>
pkgname='kraftkit-bin'
-pkgver=0.6.4
+pkgver=0.6.5
pkgrel=1
pkgdesc='Build and use highly customized and ultra-lightweight unikernels'
url='https://kraftkit.sh'
-arch=('x86_64')
+arch=('aarch64' 'x86_64')
license=('BSD-3-Clause')
provides=('kraftkit')
conflicts=('kraftkit')
-source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/unikraft/kraftkit/releases/download/v0.6.4/kraftkit_0.6.4_linux_amd64.tar.gz")
-sha256sums_x86_64=('4ddfddced7457650f24e04509b492eaa63b5e6cdbef75aff2552d4704f66fec9')
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/unikraft/kraftkit/releases/download/v0.6.5/kraftkit_0.6.5_linux_arm64.tar.gz")
+sha256sums_aarch64=('24092adcd0c52706617e3b60e83114a05d65b91c8aed1332c0a529ab4a2d2e1e')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/unikraft/kraftkit/releases/download/v0.6.5/kraftkit_0.6.5_linux_amd64.tar.gz")
+sha256sums_x86_64=('7a0192ba59d3341887ced747abed24dfea92fb982f0103e58a2ea8d3e8f71401')
package() {
# bin