summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Moldtmann2017-04-14 10:29:44 +0200
committerErik Moldtmann2017-04-14 10:29:44 +0200
commit0cdb69c700efa252cb816d3cd98ba50a34c78988 (patch)
tree7aa94aa479501ab564e9e60e6eaf00e52862b9e7
downloadaur-0cdb69c700efa252cb816d3cd98ba50a34c78988.tar.gz
commit message
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD38
-rwxr-xr-xkrautbbs9
-rw-r--r--setup.py8
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0ce165e68c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = krautbbs
+ pkgdesc = A command line lurking tool for Krautchan
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/n4n0GH/KrautBBS
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python2-pip
+ depends = python2
+ depends = python2-beautifulsoup3
+ depends = python2-requests
+ source = KrautBBS::git+https://github.com/n4n0GH/KrautBBS.git
+ source = setup.py
+ source = krautbbs
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = krautbbs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..241c2faf8f78
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.xz
+*.git
+KrautBBS
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a759a1918d47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Arschbernd <address at domain dot tld>
+pkgname=krautbbs
+_pkgname=KrautBBS
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A command line lurking tool for Krautchan"
+arch=('any')
+url="https://github.com/n4n0GH/KrautBBS"
+license=('GPL')
+groups=()
+depends=('python2' 'python2-beautifulsoup3' 'python2-requests')
+makedepends=('git' 'python2-pip')
+optdepends=()
+_pythondep='urllib2'
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$_pkgname::git+https://github.com/n4n0GH/KrautBBS.git"
+ "setup.py"
+ "krautbbs")
+noextract=()
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+build() {
+ echo "Nothing to build"
+}
+
+package() {
+ cd "$srcdir/"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ chmod +x "$pkgdir/usr/bin/krautbbs"
+}
diff --git a/krautbbs b/krautbbs
new file mode 100755
index 000000000000..c7b606424b79
--- /dev/null
+++ b/krautbbs
@@ -0,0 +1,9 @@
+#!/usr/bin/python2
+# -*- coding: utf-8 -*-
+
+import site;
+
+script = site.getsitepackages()[0]
+script += '/krautbbs/krautbbs.py'
+
+execfile(script)
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..801228bf2106
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,8 @@
+from setuptools import setup, find_packages
+setup(
+ name="krautbbs",
+ version="0.1",
+ packages=['krautbbs'],
+ package_dir={'krautbbs': 'KrautBBS'},
+ scripts=['krautbbs'],
+)