aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrantic10482017-05-04 22:39:27 +0800
committerfrantic10482017-05-04 22:39:27 +0800
commit1c6e1310509eb3ce85d2e1522569dc6187fb22c1 (patch)
treeb3bd64f4c7dbab610f392b8d2811c46f1b256d7a
parent925398a5faad8e6baad89be7563710aaf29ec15f (diff)
downloadaur-1c6e1310509eb3ce85d2e1522569dc6187fb22c1.tar.gz
1.0.0 beta
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--kreogist-mu.changelog24
-rw-r--r--kreogist-mu.desktop10
-rw-r--r--kreogist-mu.install2
5 files changed, 57 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf3e822ed9b0..acb56a6fe294 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jun 9 10:43:01 UTC 2016
+# Thu May 4 14:37:49 UTC 2017
pkgbase = kreogist-mu
pkgdesc = Fantastic cross-platform music manager.based on Qt5
- pkgver = 0.9.9.3
+ pkgver = 1.0.0beta
pkgrel = 1
epoch = 1
url = https://kreogist.github.io/Mu/
@@ -16,16 +16,16 @@ pkgbase = kreogist-mu
depends = ffmpeg
depends = phonon-qt5
depends = gst-libav
- depends = gstreamer0.10-ffmpeg
+ depends = ffmpeg
depends = desktop-file-utils
depends = hicolor-icon-theme
optdepends = gst-plugins-good: good plugin libraries
optdepends = gst-plugins-bad: bad plugin libraries
optdepends = gst-plugins-ugly: ugly plugin libraries
- source = https://github.com/Kreogist/mu-archlinux/releases/download/0.9.9.3.1/kreogist-mu-resource.tar.gz
- source = https://codeload.github.com/Kreogist/Mu/tar.gz/0.9.9.3
- sha224sums = 481526da5c0e5d53f7a95f2d7630a3b4c698fd44853f86dc2347bfc0
- sha224sums = 8767ac3acf1cd85fcab2bdac78208b1ad20bf1173b6705bca0d58391
+ source = https://codeload.github.com/Kreogist/Mu/tar.gz/1.0-beta
+ source = kreogist-mu.desktop
+ sha224sums = 9e13147a2cd7cf8a65f19153e13d1b3d6fe7add31df6c7b70d0f3227
+ sha224sums = 2f35e3f154fed55638827811b7ea3d0a34e3f7c39107bb7257a8a5f8
pkgname = kreogist-mu
diff --git a/PKGBUILD b/PKGBUILD
index c3db2f57b3ec..4d4ba2582bf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Frantic1048 <archer@frantic1048.com>
pkgname=kreogist-mu
-pkgver='0.9.9.3'
+pkgver='1.0.0beta'
+_git_tag='1.0-beta'
pkgrel=1
epoch=1
pkgdesc="Fantastic cross-platform music manager.based on Qt5"
@@ -14,7 +15,7 @@ depends=(
'ffmpeg'
'phonon-qt5'
'gst-libav'
- 'gstreamer0.10-ffmpeg'
+ 'ffmpeg'
'desktop-file-utils'
'hicolor-icon-theme'
)
@@ -32,22 +33,26 @@ makedepends=(
)
source=(
- "https://github.com/Kreogist/mu-archlinux/releases/download/$pkgver.$pkgrel/$pkgname-resource.tar.gz"
- "https://codeload.github.com/Kreogist/Mu/tar.gz/$pkgver"
+# "https://github.com/Kreogist/mu-archlinux/releases/download/$pkgver.$pkgrel/$pkgname-resource.tar.gz"
+ "https://codeload.github.com/Kreogist/Mu/tar.gz/$_git_tag"
+ "kreogist-mu.desktop"
)
-sha224sums=('481526da5c0e5d53f7a95f2d7630a3b4c698fd44853f86dc2347bfc0' '8767ac3acf1cd85fcab2bdac78208b1ad20bf1173b6705bca0d58391')
+sha224sums=('9e13147a2cd7cf8a65f19153e13d1b3d6fe7add31df6c7b70d0f3227'
+ '2f35e3f154fed55638827811b7ea3d0a34e3f7c39107bb7257a8a5f8')
build() {
mkdir -p $srcdir/Mu-build
cd $srcdir/Mu-build
- qmake "CONFIG+=release" $srcdir/Mu-$pkgver/mu.pro
+ qmake "CONFIG+=release" $srcdir/Mu-$_git_tag/mu.pro
make
}
package() {
- # excecutable
+ # rename excecutable to kreogist-mu
+ # to avoid conflicting with
mv $srcdir/Mu-build/bin/mu $srcdir/Mu-build/bin/kreogist-mu
+
install -d $pkgdir/usr/bin/
install -m775 $srcdir/Mu-build/bin/kreogist-mu $pkgdir/usr/bin/
@@ -64,7 +69,9 @@ package() {
# static resource
install -d $pkgdir/usr/share/icons/hicolor/512x512/apps/
- install -m664 $srcdir/$pkgname-resource/$pkgname.png $pkgdir/usr/share/icons/hicolor/512x512/apps/
+ install -m664 $srcdir/Mu-$_git_tag/src/resource/icon/mu.png \
+ $pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png
+
install -d $pkgdir/usr/share/applications/
- install -m664 $srcdir/$pkgname-resource/$pkgname.desktop $pkgdir/usr/share/applications/
+ install -m664 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/
}
diff --git a/kreogist-mu.changelog b/kreogist-mu.changelog
index 0a6a1b802223..aaed757e8514 100644
--- a/kreogist-mu.changelog
+++ b/kreogist-mu.changelog
@@ -1,3 +1,27 @@
+1.0.0beta
+----------
+This is a major minor update to 0.9.9.3. It fixed several critical bugs when facing some extreme conditions.
+
+The update blog is below:
+
+ Use the new singleton application class instead of using shared memory.
+ Update the bass to the latest version.
+ Reduce the file find signal number. Using the patch list to compress the signal.
+ Fixed the error which might delete all the files under the running directory bug.
+ Fixed the genre images folder get from root bug.
+
+The graduation thesis took far more time than I expected. The update progress could be slow, but I will do my best to upgrade the application. Currently I am working on the following parts.
+
+ Configuration Panels: In 1.0 final release, we will provide custom settings.
+ Format Converting: In 1.0 final release, we will bundle FFMPEG as one part of Mu and providing file format converting function.
+ Spliting: In 1.0 final release, we will provide the CUE file spliting function.
+ Perhaps new backends: It is time to change the backend from two to one. Previously I was trying to use GStreamer to unified the backend. One of our user suggesting me to use the libmpv. To tell the truth, I was trying to add one MPV backend before, however due to my personal skill, I didn't realize it. Some new information gives me hope. This feature may not appear in 1.0 release, but must be appeared in the future release.
+
+Hope you can enjoy the new version μ!
+
+〜μ'sic Forever♪♪♪♪♪♪♪♪♪〜
+
+
0.9.9.3
----------
diff --git a/kreogist-mu.desktop b/kreogist-mu.desktop
new file mode 100644
index 000000000000..41b1a3052ea4
--- /dev/null
+++ b/kreogist-mu.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=μ
+GenericName=Music Manager
+Exec=kreogist-mu
+Icon=kreogist-mu
+Terminal=false
+Categories=AudioVideo;Audio;Music;Player;Qt;
+StartupNotify=false
+MimeType=audio/flac;audio/aac;audio/mp2;audio/mp4;audio/mpeg;audio/x-ape;audio/x-musepack;audio/x-aif;audio/x-aiff;audio/oga;audio/ogg;audio/x-flac+ogg;audio/x-vorbis+ogg;audio/x-opus+ogg;audio/x-speex;audio/x-tta;audio/x-wav;audio/x-wavpack;application/x-cue;x-content/audio-player \ No newline at end of file
diff --git a/kreogist-mu.install b/kreogist-mu.install
deleted file mode 100644
index 0dca8f97d556..000000000000
--- a/kreogist-mu.install
+++ /dev/null
@@ -1,2 +0,0 @@
-update-desktop-database -q
-gtk-update-icon-cache