aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrantic10482016-04-05 18:42:51 +0800
committerfrantic10482016-04-05 18:46:40 +0800
commite6de431878032b0f94f27a81351e5bbc49b416c1 (patch)
treeac090f2293892a81b3433bb6518f687dc7a64321
parentcbbdb76ceeeb5a08996d267c8ada170d99e35bef (diff)
downloadaur-e6de431878032b0f94f27a81351e5bbc49b416c1.tar.gz
update to 0.9.9.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD68
-rw-r--r--kreogist-mu.changelog59
-rw-r--r--kreogist-mu.install2
4 files changed, 127 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd8d1e053cd4..1c8e9df531b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,32 @@
+# Generated by mksrcinfo v8
+# Tue Apr 5 10:42:28 UTC 2016
pkgbase = kreogist-mu
pkgdesc = Fantastic cross-platform music manager.based on Qt5
- pkgver = 0.9.2
+ pkgver = 0.9.9.1
pkgrel = 1
epoch = 1
url = https://kreogist.github.io/Mu/
+ install = kreogist-mu.install
changelog = kreogist-mu.changelog
arch = x86_64
license = GPL
- depends = qt5-base
+ makedepends = git
+ makedepends = gcc
+ makedepends = qt5-tools
depends = pulseaudio
depends = ffmpeg
depends = phonon-qt5
depends = gst-libav
depends = gstreamer0.10-ffmpeg
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
optdepends = gst-plugins-good: good plugin libraries
optdepends = gst-plugins-bad: bad plugin libraries
optdepends = gst-plugins-ugly: ugly plugin libraries
- source = https://github.com/frantic1048/mu-archlinux/releases/download/0.9.2/kreogist-mu-0.9.2-x86_64.7z
- md5sums = abbe752b7e9a608cbe52933267fefba7
+ source = https://github.com/Kreogist/mu-archlinux/releases/download/0.9.9.1.1/kreogist-mu-resource.tar.gz
+ source = https://codeload.github.com/Kreogist/Mu/tar.gz/0.9.9.1
+ sha224sums = 1f0247a0f08cffc062f80ca68fa5e24c64c16d559aade32524d66cc3
+ sha224sums = 2a9d7ee064b5d8623691a0bcd0047ae876e7aaaab77bdfad4e9e23fe
pkgname = kreogist-mu
diff --git a/PKGBUILD b/PKGBUILD
index 41b65e10e4ca..1f1a7bacb9d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,74 @@
-# Maintainer: Frantic1048 <Archer@frantic1048.com>
+# Maintainer: Frantic1048 <archer@frantic1048.com>
pkgname=kreogist-mu
-pkgver='0.9.2'
+pkgver='0.9.9.1'
pkgrel=1
epoch=1
pkgdesc="Fantastic cross-platform music manager.based on Qt5"
-changelog="kreogist-mu.changelog"
arch=('x86_64')
url="https://kreogist.github.io/Mu/"
license=('GPL')
+changelog="$pkgname.changelog"
+install="$pkgname.install"
depends=(
- 'qt5-base'
'pulseaudio'
'ffmpeg'
'phonon-qt5'
'gst-libav'
- 'gstreamer0.10-ffmpeg')
+ 'gstreamer0.10-ffmpeg'
+ 'desktop-file-utils'
+ 'hicolor-icon-theme'
+)
+
optdepends=(
'gst-plugins-good: good plugin libraries'
'gst-plugins-bad: bad plugin libraries'
'gst-plugins-ugly: ugly plugin libraries'
)
-changelog=$pkgname.changelog
-source=("https://github.com/frantic1048/mu-archlinux/releases/download/$pkgver/$pkgname-$pkgver-$arch.7z")
-md5sums=('abbe752b7e9a608cbe52933267fefba7')
+
+makedepends=(
+ 'git'
+ 'gcc'
+ 'qt5-tools'
+)
+
+source=(
+ "https://github.com/Kreogist/mu-archlinux/releases/download/$pkgver.$pkgrel/$pkgname-resource.tar.gz"
+ "https://codeload.github.com/Kreogist/Mu/tar.gz/$pkgver"
+)
+
+sha224sums=(
+ '1f0247a0f08cffc062f80ca68fa5e24c64c16d559aade32524d66cc3'
+ '2a9d7ee064b5d8623691a0bcd0047ae876e7aaaab77bdfad4e9e23fe'
+)
+
+build() {
+ mkdir -p $srcdir/Mu-build
+ cd $srcdir/Mu-build
+ qmake "CONFIG+=release" $srcdir/Mu-$pkgver/mu.pro
+ make
+}
package() {
- cd "$pkgname-$pkgver-$arch"
- install -d "${pkgdir}/usr/bin/"
- install -m=775 $pkgname "${pkgdir}/usr/bin"
- install -d "${pkgdir}/usr/share/icons/hicolor/512x512/apps/"
- install -m=664 $pkgname.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/"
- install -d "${pkgdir}/usr/share/applications/"
- install -m=664 $pkgname.desktop "${pkgdir}/usr/share/applications/"
+ # excecutable
+ mv $srcdir/Mu-build/bin/mu $srcdir/Mu-build/bin/kreogist-mu
+ install -d $pkgdir/usr/bin/
+ install -m775 $srcdir/Mu-build/bin/kreogist-mu $pkgdir/usr/bin/
+
+ # i18n files
+ # https://github.com/Kreogist/Mu/issues/17#issuecomment-164236195
+ install -d $pkgdir/usr/share/Kreogist/mu/Language/
+ for f in $srcdir/Mu-build/bin/*.qm
+ do
+ baseName=$(basename $f)
+ languageName="${baseName%.qm}"
+ install -d $pkgdir/usr/share/Kreogist/mu/Language/$languageName/
+ install -m664 $f $pkgdir/usr/share/Kreogist/mu/Language/$languageName/
+ done
+
+ # static resource
+ install -d $pkgdir/usr/share/icons/hicolor/512x512/apps/
+ install -m664 $srcdir/$pkgname-resource/$pkgname.png $pkgdir/usr/share/icons/hicolor/512x512/apps/
+ install -d $pkgdir/usr/share/applications/
+ install -m664 $srcdir/$pkgname-resource/$pkgname.desktop $pkgdir/usr/share/applications/
}
diff --git a/kreogist-mu.changelog b/kreogist-mu.changelog
index 174a8c2fbd48..f23632b13fdd 100644
--- a/kreogist-mu.changelog
+++ b/kreogist-mu.changelog
@@ -1,3 +1,62 @@
+0.9.9.1
+
+This is a bug fixed version of 0.9.9, it fixed several critical bugs.
+
+1.0 may be released in the next month. Prepare to get your 1.0!
+Before that, you can register a Kreogist Account first. I will appreciate. :)
+
+P.S.: Hope the final live will be super success. I could do nothing but bless their success.
+
+〜μ'sic Forever♪♪♪♪♪♪♪♪♪〜
+
+
+0.9.9
+
+This is the last major release of 0.9. So we skip several version, and the next version will be 1.0.
+In this version, Kreogist μ add our Kreogist Account system, it supports for our third-party music resources. Now it support for customize your nickname, avatar.
+Kreogist Account will be used for all Kreogist products. Have fun with this last 0.9 version product.
+
+Thanks for all the staff of Kreogist Dev Team:
+Luming Wang
+Dayou Zhang
+Jiayi Zhang
+Youraku
+Joe Johnson
+Freddie
+Nick Tang
+Frantic1048
+Yayuan Yan
+
+〜μ'sic Forever♪♪♪♪♪♪♪♪♪〜
+
+
+0.9.4:
+
+This is a major updated version. It contains the following updates and features.
+
+When dragging songs in the music library tabs, the playlist float panel will be shown. Now you can create playlist or add to playlist directly when dragging.
+Optimized for all UI animations.
+Adapt for OS X 10.11 compiler.
+Fixed the exception bug when playlist the deleted CUE file.
+Fixed the automatically downloaded lyrics will replace the manually download lyrics.
+Fixed the main window might be shown as well as the mini player.
+Fixed the album art image won't be shown at album detail widget.
+The following version will be focus on the following things, which is all prepared for our online music parts:
+
+Notification Center
+User Account System
+Control Panel
+And then our product will become the third-party client for several online music store. Hope you will enjoy this version.
+
+〜μ'sic Forever♪♪♪♪♪♪♪♪♪〜
+
+0.9.3:
+
+This is a major updated version. It contains several major updates and features.
+Now it could edit ID3v1, ID3v2 and APEv2 tag. The UI is also optimized for speed. And several bug fixed.
+Happy new year and μ'sic start!
+
+
0.9.2:
This is a Linux enhanced version, and it's a major update.
diff --git a/kreogist-mu.install b/kreogist-mu.install
new file mode 100644
index 000000000000..0dca8f97d556
--- /dev/null
+++ b/kreogist-mu.install
@@ -0,0 +1,2 @@
+update-desktop-database -q
+gtk-update-icon-cache