summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-10-11 15:39:01 +0200
committersl1pkn072015-10-11 15:39:01 +0200
commit0beb2bd8aeffcf0178b47c9043c5168a33542ec9 (patch)
tree64acca8d1d8ec9a2f12b742765383848b4e7b2e8
downloadaur-0beb2bd8aeffcf0178b47c9043c5168a33542ec9.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD57
-rw-r--r--krita-git.install13
4 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cd5f664f2df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = krita-git
+ pkgdesc = A free digital painting application. Digital Painting, Creative Freedom!. (GIT Version)
+ pkgver = 3.0.89.r38940.fcf9a43
+ pkgrel = 1
+ url = http://www.krita.org/
+ install = krita-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = boost
+ makedepends = vc
+ makedepends = python
+ depends = fftw
+ depends = gsl
+ depends = libkdcraw-frameworks-git
+ depends = opencolorio
+ depends = boost-libs
+ depends = exiv2
+ depends = openexr
+ depends = poppler-qt5
+ depends = kio
+ provides = krita
+ conflicts = krita
+ conflicts = calligra-krita-git
+ source = git://anongit.kde.org/krita.git
+ sha1sums = SKIP
+
+pkgname = krita-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3137b71a5aed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!krita-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..495e092665fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+#Contributor: Bruno Pagani (a.k.a. ArchangeGabriel) <bruno.n.pagani at gmail dot com>
+
+pkgname=krita-git
+pkgver=3.0.89.r38940.fcf9a43
+pkgrel=1
+pkgdesc="A free digital painting application. Digital Painting, Creative Freedom!. (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://www.krita.org/"
+license=('GPL2')
+depends=('fftw'
+ 'gsl'
+ 'libkdcraw-frameworks-git'
+ 'opencolorio'
+ 'boost-libs'
+ 'exiv2'
+ 'openexr'
+ 'poppler-qt5'
+ 'kio'
+ )
+makedepends=('extra-cmake-modules'
+ 'git'
+ 'boost'
+ 'vc'
+ 'python'
+ )
+provides=('krita')
+conflicts=('krita' 'calligra-krita-git')
+install=krita-git.install
+source=('git://anongit.kde.org/krita.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd krita
+ _ver="$(cat CMakeLists.txt | grep -m3 -e CALLIGRA_STABLE_VERSION_MAJOR -e CALLIGRA_STABLE_VERSION_MINOR -e CALLIGRA_VERSION_RELEASE | cut -d ')' -f1 | grep -o "[[:digit:]]*" | paste -sd'.')"
+ echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../krita \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTING=OFF
+
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/krita-git.install b/krita-git.install
new file mode 100644
index 000000000000..3b3aff7d9e79
--- /dev/null
+++ b/krita-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-mime-database usr/share/mime &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}