summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2016-08-06 13:52:13 +0200
committerStefan Husmann2016-08-06 13:52:13 +0200
commitfa85b73b15fc04bbc505f9b080815f9afc9d58ee (patch)
treeccb2ad3249fbf0f00009cf6f0bb6ac8adc4e7b2b
parente68c0d6a1d888547d604875c888e4eb2a8303eb8 (diff)
downloadaur-fa85b73b15fc04bbc505f9b080815f9afc9d58ee.tar.gz
add a CXXFLAGS switch and an option \!makeflags
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ad7505cd119..120d2e15cbd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Aug 4 18:16:14 UTC 2016
pkgbase = krita-git
pkgdesc = A free digital painting application. Digital Painting, Creative Freedom!. (GIT Version)
- pkgver = 3.0.89r41125.8be941a
+ pkgver = 3.0.89r41232.6530b6d
pkgrel = 1
url = http://www.krita.org
arch = i686
@@ -35,6 +33,7 @@ pkgbase = krita-git
provides = calligra-krita
conflicts = krita
conflicts = calligra-krita
+ options = !makeflags
source = git://anongit.kde.org/krita.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5844ea626833..1a7756c9b06e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=krita-git
-pkgver=3.0.89r41125.8be941a
+pkgver=3.0.89r41232.6530b6d
pkgrel=1
pkgdesc="A free digital painting application. Digital Painting, Creative Freedom!. (GIT Version)"
arch=('i686' 'x86_64')
@@ -39,6 +39,7 @@ provides=('krita' 'calligra-krita')
conflicts=('krita' 'calligra-krita')
source=('git://anongit.kde.org/krita.git')
sha1sums=('SKIP')
+options=('!makeflags')
pkgver() {
cd krita
@@ -59,13 +60,12 @@ prepare() {
build() {
cd build
- cmake ../krita \
+ CXXFLAGS=' -std=c++11' cmake ../krita \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
- -DBUILD_TESTING=OFF
-
+ -DBUILD_TESTING=OFF
make
}