summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsanbikappa2023-08-04 11:40:49 +0800
committersanbikappa2023-08-04 11:40:49 +0800
commit579598f5ec5f55c5f50e021974471c2b65cbb6bf (patch)
tree3f8ad43d40b226bbb2b6541d68ce9d38037c7b46
downloadaur-579598f5ec5f55c5f50e021974471c2b65cbb6bf.tar.gz
setup repo
-rw-r--r--.SRCINFO18
-rw-r--r--.install18
-rw-r--r--PKGBUILD36
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9e98841a3a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = krita-plugin-pythonplugindevelopertools-git
+ pkgdesc = Python plugin for Krita that assists with making python plugins for Krita
+ pkgver = r37.46a671a
+ pkgrel = 1
+ url = https://github.com/KnowZero/Krita-PythonPluginDeveloperTools
+ install = .install
+ arch = any
+ license = unknow
+ depends = krita
+ depends = python-pyqt5
+ provides = krita-plugin-pythonplugindevelopertools
+ provides = krita-plugin-pythonplugindevelopertools-bin
+ conflicts = krita-plugin-pythonplugindevelopertools
+ conflicts = krita-plugin-pythonplugindevelopertools-bin
+ source = krita-plugin-pythonplugindevelopertools-git-r37.46a671a::git+https://github.com/KnowZero/Krita-PythonPluginDeveloperTools
+ md5sums = SKIP
+
+pkgname = krita-plugin-pythonplugindevelopertools-git
diff --git a/.install b/.install
new file mode 100644
index 000000000000..11d08f6b50bc
--- /dev/null
+++ b/.install
@@ -0,0 +1,18 @@
+# arg 1: the new package version
+post_install() {
+ echo ""
+ echo "***************************************************************"
+ echo "(1) After installed this plugin, please open Krita then go to:"
+ echo "\"Settings -> Configure Krita -> Python Plugins Manager\""
+ echo "to enable the plugin."
+ echo ""
+ echo "(2) Please note that package maintainer changed the"
+ echo "PluginDevTools.KritaAPI.*.zip file's path from:"
+ echo " \"/usr/share/krita/pykrita/\""
+ echo "to:"
+ echo " \"~/.cache/krita/\""
+ echo "to avoid writing the system path."
+ echo "***************************************************************"
+ echo ""
+}
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1975e64087b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+
+# Maintainer: Mikata Riko <sanbikappa@qq.com>
+
+pkgname=krita-plugin-pythonplugindevelopertools-git
+pkgver=r37.46a671a
+pkgrel=1
+epoch=
+pkgdesc="Python plugin for Krita that assists with making python plugins for Krita"
+arch=('any')
+url="https://github.com/KnowZero/Krita-PythonPluginDeveloperTools"
+license=('unknow')
+depends=('krita' 'python-pyqt5')
+provides=('krita-plugin-pythonplugindevelopertools' 'krita-plugin-pythonplugindevelopertools-bin')
+conflicts=('krita-plugin-pythonplugindevelopertools' 'krita-plugin-pythonplugindevelopertools-bin')
+install=.install
+source=("$pkgname-$pkgver::git+https://github.com/KnowZero/Krita-PythonPluginDeveloperTools")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # set the PluginDevTools.KritaAPI.*.zip file's save path to ~/.cache/krita/
+ sed -i 's/os.path.dirname(os.path.realpath(__file__))/os.path.join(os.path.expanduser("~"),".cache","krita","PluginDevTools")/' plugindevtools/PluginDevTools/GetKritaAPI.py
+
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/share/krita/pykrita/"
+ cp -r plugindevtools/{PluginDevTools,PluginDevTools.desktop} "$pkgdir/usr/share/krita/pykrita/"
+
+}