summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Mangold2023-11-14 08:38:21 +0100
committerOliver Mangold2023-11-14 08:38:21 +0100
commit2be50b861e46bd32a66de7d3e01e2c8eb089f640 (patch)
tree9faf2857c8f25b463e9af967fdad06e678bbd455
parenteea05bab9d3af53e94afca87205861bda61e006e (diff)
downloadaur-2be50b861e46bd32a66de7d3e01e2c8eb089f640.tar.gz
simplifying configure options
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6010cafe7cf..26ebf9cb37b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,10 +22,8 @@ prepare() {
build() {
cd ${pkgname}-${pkgver}
- ./configure --libdir=/usr/lib \
- --sbindir=/usr/bin \
- --enable-publicandocs \
- --with-systemddir=/usr/lib/systemd/system
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc
# Fight unused direct deps
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' -e 's/ if test "$export_dynamic" = yes && test -n "$export_dynamic_flag_spec"; then/ func_append compile_command " -Wl,-O1,--as-needed"\n func_append finalize_command " -Wl,-O1,--as-needed"\n\0/' libtool
make V=0