summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Reitz2018-04-11 16:50:36 +0200
committerMax Reitz2018-04-11 17:08:54 +0200
commit3a6e58536fed6aaf108127112c41fb2b7aea3573 (patch)
tree4b1f70f2003ee1aaa68c090f5eda2d3f814cec02
downloadaur-3a6e58536fed6aaf108127112c41fb2b7aea3573.tar.gz
Initial commit: version r32.96f8e44
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD39
-rw-r--r--krunner-mpd-git.install18
4 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a3b700444d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = krunner-mpd-git
+ pkgdesc = KRunner plugin to control an MPD server
+ pkgver = r32.96f8e44
+ pkgrel = 1
+ url = https://github.com/XanClic/krunner-mpd
+ install = krunner-mpd-git.install
+ arch = any
+ license = GPL3
+ makedepends = coreutils
+ makedepends = kdelibs4support
+ makedepends = make
+ depends = dbus
+ depends = plasma-workspace
+ depends = ruby
+ depends = ruby-dbus
+ depends = ruby-i18n
+ depends = ruby-locale
+ depends = ruby-ruby-mpd
+ provides = krunner-mpd
+ conflicts = krunner-mpd
+ source = krunner-mpd-git::git://github.com/XanClic/krunner-mpd.git
+ md5sums = SKIP
+
+pkgname = krunner-mpd-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0e63c7e5696a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+build/
+update.sh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dea3438d3fd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Max Reitz <xanclic at xanclic dot moe>
+pkgname=krunner-mpd-git
+pkgver=r32.96f8e44
+pkgrel=1
+pkgdesc="KRunner plugin to control an MPD server"
+arch=('any')
+url="https://github.com/XanClic/krunner-mpd"
+license=('GPL3')
+depends=('dbus'
+ 'plasma-workspace'
+ 'ruby'
+ 'ruby-dbus'
+ 'ruby-i18n'
+ 'ruby-locale'
+ 'ruby-ruby-mpd')
+makedepends=('coreutils'
+ 'kdelibs4support'
+ 'make')
+provides=('krunner-mpd')
+conflicts=('krunner-mpd')
+install=$pkgname.install
+source=("$pkgname::git://github.com/XanClic/krunner-mpd.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ ./configure --prefix=/usr --skip-bundle-install
+ make
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/krunner-mpd-git.install b/krunner-mpd-git.install
new file mode 100644
index 000000000000..0e6071078a41
--- /dev/null
+++ b/krunner-mpd-git.install
@@ -0,0 +1,18 @@
+post_install() {
+ echo "Run 'kquitapp5 krunner && kstart5 krunner' to restart krunner so it finds"
+ echo "krunner-mpd (you may need to enable it in the krunner settings as well)."
+}
+
+post_upgrade() {
+ # Kill the old instance so that krunner launches the new version
+
+ local _pid_dir=$XDG_RUNTIME_DIR
+ if [ -z "$_pid_dir" ]; then
+ _pid_dir="/var/run/users/$(id -u)"
+ fi
+
+ local _pid_file="$_pid_dir/krunner-mpd.pid"
+ if [ -f "$_pid_file" ]; then
+ kill "$(cat "$_pid_file")"
+ fi
+}