summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fürmetz2017-04-11 17:27:39 +0700
committerLukas Fürmetz2017-04-11 17:27:39 +0700
commitb407469f571d9e10b32af9ac7492233651d7fe74 (patch)
tree1265dd6d067c67077db2c276d45cc6e68639a2dd
downloadaur-b407469f571d9e10b32af9ac7492233651d7fe74.tar.gz
v1.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c1458a40f4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = krunner-pass
+ pkgdesc = A krunner plugin to retrieve a password from the password-store (https://www.passwordstore.org/)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/akermu/krunner-pass
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ depends = krunner
+ depends = qt5-base
+ depends = ki18n
+ source = https://github.com/akermu/krunner-symbols/releases/download/v1.0.0/krunner-pass-1.0.0.tar.gz
+
+pkgname = krunner-pass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..588fff87c185
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lukas Fürmetz <fuermetz@mailbox.org>
+pkgname=krunner-pass
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A krunner plugin to retrieve a password from the password-store (https://www.passwordstore.org/)"
+arch=('any')
+url="https://github.com/akermu/krunner-pass"
+license=('GPL')
+depends=('krunner' 'qt5-base' 'ki18n')
+makedepends=('cmake' 'extra-cmake-modules')
+source=("https://github.com/akermu/krunner-pass/archive/v${pkgver}.tar.gz")
+md5sums=("fbdc594d5b04167e70773231efa8d481")
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ../${pkgname}-${pkgver} -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` -DQT_PLUGIN_INSTALL_DIR=`kf5-config --qt-plugins` -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make install DESTDIR="${pkgdir}"
+}