summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Mumford2019-09-10 11:30:16 +0100
committerStuart Mumford2019-09-10 11:30:16 +0100
commit1987052b70a65942ea0180794e9c0ac15cf0af06 (patch)
tree715ba7eba0892a0af5e23aecd83d16f09f6e1eed
downloadaur-1987052b70a65942ea0180794e9c0ac15cf0af06.tar.gz
Add initial version of git package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2740576dab6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = krunner-pass-git
+ pkgdesc = A krunner plugin to retrieve a password from the password-store (https://www.passwordstore.org/)
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/akermu/krunner-pass
+ arch = any
+ license = GPL
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ depends = krunner
+ depends = qt5-base
+ depends = ki18n
+ source = git://github.com/akermu/krunner-pass
+ md5sums = SKIP
+
+pkgname = krunner-pass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c82e857d5a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stuart Mumford <stuart@cadair.com>
+pkgname=krunner-pass-git
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A krunner plugin to retrieve a password from the password-store (https://www.passwordstore.org/)"
+arch=('any')
+url="https://github.com/akermu/krunner-pass"
+license=('GPL')
+depends=('krunner' 'qt5-base' 'ki18n')
+makedepends=('cmake' 'extra-cmake-modules')
+source=("git://github.com/akermu/krunner-pass")
+md5sums=('SKIP')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ../krunner-pass -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` -DQT_PLUGIN_INSTALL_DIR=`kf5-config --qt-plugins` -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make install DESTDIR="${pkgdir}"
+}