summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Mumford2022-06-13 13:08:06 +0100
committerStuart Mumford2022-06-13 13:08:06 +0100
commit646c7d3e7295bf5c61234f5fba379b8216ef1a96 (patch)
tree657add192048474c7bf8c8c34244ba59977a7e0e
parent1987052b70a65942ea0180794e9c0ac15cf0af06 (diff)
downloadaur-646c7d3e7295bf5c61234f5fba379b8216ef1a96.tar.gz
Update pkgbuild with patch
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 40 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2740576dab6b..0b168a630de2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,25 @@
pkgbase = krunner-pass-git
pkgdesc = A krunner plugin to retrieve a password from the password-store (https://www.passwordstore.org/)
- pkgver = 1.3.0
+ pkgver = 1.3.0.r15.gce0fbda
pkgrel = 1
url = https://github.com/akermu/krunner-pass
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = aarch64
license = GPL
+ makedepends = git
makedepends = cmake
makedepends = extra-cmake-modules
+ makedepends = qt5-tools
depends = krunner
depends = qt5-base
depends = ki18n
- source = git://github.com/akermu/krunner-pass
+ depends = kcmutils
+ provides = krunner-pass=1.3.0.r15.gce0fbda
+ conflicts = krunner-pass
+ source = git+https://github.com/akermu/krunner-pass
+ source = fix_build.patch::https://github.com/akermu/krunner-pass/pull/21.patch
+ md5sums = SKIP
md5sums = SKIP
pkgname = krunner-pass-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0c82e857d5a2..8ad5d71c34d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,40 @@
# Maintainer: Stuart Mumford <stuart@cadair.com>
pkgname=krunner-pass-git
-pkgver=1.3.0
+pkgver=1.3.0.r15.gce0fbda
pkgrel=1
pkgdesc="A krunner plugin to retrieve a password from the password-store (https://www.passwordstore.org/)"
-arch=('any')
+arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/akermu/krunner-pass"
license=('GPL')
-depends=('krunner' 'qt5-base' 'ki18n')
-makedepends=('cmake' 'extra-cmake-modules')
-source=("git://github.com/akermu/krunner-pass")
-md5sums=('SKIP')
+provides=("krunner-pass=${pkgver}")
+conflicts=('krunner-pass')
+depends=('krunner' 'qt5-base' 'ki18n' 'kcmutils')
+makedepends=('git' 'cmake' 'extra-cmake-modules' 'qt5-tools')
+source=('git+https://github.com/akermu/krunner-pass'
+ 'fix_build.patch::https://github.com/akermu/krunner-pass/pull/21.patch')
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "krunner-pass"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare()
+{
+ cd krunner-pass
+ patch -p1 -i ../fix_build.patch
+}
build() {
- mkdir -p build
- cd build
- cmake ../krunner-pass -DCMAKE_INSTALL_PREFIX=`kf5-config --prefix` -DQT_PLUGIN_INSTALL_DIR=`kf5-config --qt-plugins` -DCMAKE_BUILD_TYPE=Release
- make
+ cmake -B build -S krunner-pass \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX=$(qtpaths --install-prefix) \
+ -DQT_PLUGIN_INSTALL_DIR=$(qtpaths --plugin-dir) \
+ -Wno-dev
+ cmake --build build
}
package() {
- cd build
- make install DESTDIR="${pkgdir}"
+ DESTDIR="$pkgdir" VERBOSE=1 cmake --install build
}