summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsirlucjan2017-02-22 17:07:52 +0100
committersirlucjan2017-02-22 17:07:52 +0100
commit7c5df5ebcdf6dc32007062bbc6ba83c7540a9609 (patch)
tree9efdd34d4705b9e4c5d3285703692863bfcf90d5
parent6cfad1efbb520a1552f878beb58bfc35b8136a7a (diff)
downloadaur-7c5df5ebcdf6dc32007062bbc6ba83c7540a9609.tar.gz
Update to the newest commit, clean up && improvement
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD45
2 files changed, 72 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa88824f3162..4c2ba65da3ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,54 @@
-# Generated by mksrcinfo v8
-# Sat Oct 8 14:21:59 UTC 2016
pkgbase = krusader-git
pkgdesc = Advanced twin panel file manager for KDE. (GIT version)
- pkgver = 2.5.0.beta.r5294.d0a854f
+ pkgver = 2.5.1.beta.r5546.g94a07c18
pkgrel = 1
url = http://www.krusader.org
arch = i686
arch = x86_64
license = GPL
+ makedepends = cmake
makedepends = extra-cmake-modules
- makedepends = kdoctools
- makedepends = git
makedepends = python
- makedepends = acl
+ makedepends = git
+ depends = karchive
+ depends = kbookmarks
+ depends = kcodecs
+ depends = kcompletion
+ depends = kcoreaddons
+ depends = kconfig
+ depends = kdoctools
+ depends = ki18n
+ depends = kiconthemes
+ depends = kitemviews
+ depends = kio
+ depends = knotifications
depends = kparts
+ depends = solid
+ depends = ktextwidgets
+ depends = kwallet
+ depends = kwidgetsaddons
+ depends = kwindowsystem
+ depends = kxmlgui
+ depends = kguiaddons
depends = hicolor-icon-theme
- optdepends = acl: Access control list utilities
+ optdepends = xz: LZMA and XZ archive support
+ optdepends = unzip: ZIP decompression support
+ optdepends = zip: ZIP archive support
+ optdepends = lhasa: LHA archive support
+ optdepends = cpio: cpio archive support
+ optdepends = unrar: RAR decompression support
+ optdepends = rar: RAR archive support
+ optdepends = arj: ARJ archive support
+ optdepends = unarj: ARJ decompression support
+ optdepends = unace: ACE decompression support
+ optdepends = p7zip: 7z archive support
+ optdepends = keditbookmarks: Manage Bookmarks functionality
+ optdepends = kde-cli-tools: manage file associations
+ optdepends = kompare: file contents comparison
+ optdepends = kdiff3: file contents comparison
+ optdepends = krename: advanced rename tool
+ optdepends = konsole: terminal
+ optdepends = ktexteditor: file editing support
provides = krusader
conflicts = krusader
source = git://anongit.kde.org/krusader
diff --git a/PKGBUILD b/PKGBUILD
index a895e22bdfe3..8493d1941a11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,41 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Piotr Gorski <lucjan.lucjanov@gmail.com>
+# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=krusader-git
-pkgver=2.5.0.beta.r5294.d0a854f
+pkgver=2.5.1.beta.r5546.g94a07c18
pkgrel=1
pkgdesc="Advanced twin panel file manager for KDE. (GIT version)"
arch=('i686' 'x86_64')
url='http://www.krusader.org'
license=('GPL')
-depends=('kparts'
- 'hicolor-icon-theme'
- )
-makedepends=('extra-cmake-modules'
- 'kdoctools'
- 'git'
- 'python'
- 'acl'
- )
-optdepends=('acl: Access control list utilities')
+depends=('karchive' 'kbookmarks' 'kcodecs' 'kcompletion' 'kcoreaddons' 'kconfig'
+ 'kdoctools' 'ki18n' 'kiconthemes' 'kitemviews' 'kio' 'knotifications'
+ 'kparts' 'solid' 'ktextwidgets' 'kwallet' 'kwidgetsaddons' 'kwindowsystem'
+ 'kxmlgui' 'kguiaddons' 'hicolor-icon-theme')
+makedepends=('cmake' 'extra-cmake-modules' 'python' 'git')
+optdepends=(
+ # archive formats
+ # look for KrServices::cmdExist calls
+ 'xz: LZMA and XZ archive support'
+ 'unzip: ZIP decompression support'
+ 'zip: ZIP archive support'
+ 'lhasa: LHA archive support'
+ 'cpio: cpio archive support'
+ 'unrar: RAR decompression support'
+ 'rar: RAR archive support'
+ 'arj: ARJ archive support'
+ 'unarj: ARJ decompression support'
+ 'unace: ACE decompression support'
+ 'p7zip: 7z archive support'
+ # additional apps
+ 'keditbookmarks: Manage Bookmarks functionality'
+ 'kde-cli-tools: manage file associations'
+ 'kompare: file contents comparison'
+ 'kdiff3: file contents comparison'
+ 'krename: advanced rename tool'
+ 'konsole: terminal'
+ 'ktexteditor: file editing support'
+)
provides=('krusader')
conflicts=('krusader')
source=('git://anongit.kde.org/krusader')
@@ -25,7 +44,7 @@ sha1sums=('SKIP')
pkgver() {
cd krusader
_ver="$(cat CMakeLists.txt | grep -m1 'set(VERSION' | cut -d '"' -f2 | tr - .)"
- echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ echo "${_ver}.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
prepare() {