summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-14 10:09:09 +0800
committerzxp198210052023-09-14 10:09:09 +0800
commitaff46e800a02e04a94f11ae244a261697f4a9f36 (patch)
treed831eb03683d2281e79045ebb57e51069bc9ca77
parent08f28165bde32571e2ea760bf1c6b8d3ac197ca4 (diff)
downloadaur-aff46e800a02e04a94f11ae244a261697f4a9f36.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5933e7a0b58d..91792376bd0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = krux-installer-bin
pkgdesc = A GUI based application to flash Krux firmware on K210 based devices (WIP)
pkgver = 0.0.1_alpha_4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/selfcustody/krux-installer
arch = x86_64
license = MIT
@@ -10,7 +10,7 @@ pkgbase = krux-installer-bin
provides = krux-installer=0.0.1_alpha_4
conflicts = krux-installer
source = krux-installer-0.0.1_alpha_4.AppImage::https://github.com/selfcustody/krux-installer/releases/download/v0.0.1-alpha-4/KruxInstaller-0.0.1-alpha-4.AppImage
- source = LICENSE::https://raw.githubusercontent.com/selfcustody/krux-installer/main/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/selfcustody/krux-installer/v0.0.1-alpha-4/LICENSE
source = krux-installer.sh
sha256sums = dfaede387473c3a7f494b79e963c409e365f3df59dc67ec003a65b37cb7884db
sha256sums = b68fe242a948dedae52171bf19978e0926f357599b67f111f86fc2d23e20c9ff
diff --git a/PKGBUILD b/PKGBUILD
index 42c869a7ef2d..3ca5ba42c477 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=krux-installer-bin
_appname=KruxInstaller
pkgver=0.0.1_alpha_4
-pkgrel=1
+pkgrel=2
pkgdesc="A GUI based application to flash Krux firmware on K210 based devices (WIP)"
arch=('x86_64')
url="https://github.com/selfcustody/krux-installer"
@@ -11,7 +11,7 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=('bash' 'electron24')
source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver//_/-}/${_appname}-${pkgver//_/-}.AppImage"
- "LICENSE::https://raw.githubusercontent.com/selfcustody/krux-installer/main/LICENSE"
+ "LICENSE::https://raw.githubusercontent.com/selfcustody/krux-installer/v${pkgver//_/-}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('dfaede387473c3a7f494b79e963c409e365f3df59dc67ec003a65b37cb7884db'
'b68fe242a948dedae52171bf19978e0926f357599b67f111f86fc2d23e20c9ff'
@@ -19,12 +19,12 @@ sha256sums=('dfaede387473c3a7f494b79e963c409e365f3df59dc67ec003a65b37cb7884db'
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
- sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file