summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-08-30 17:06:37 +0200
committerJose Riha2021-08-30 17:06:37 +0200
commit8525d5a504c644110644d0ad45b8f1d7d8e344d4 (patch)
treeb19da5bbf85db1f3705775cf6d513015ca850c01
parent29de15edceaa453643bfec69ea455da2a3797fde (diff)
downloadaur-8525d5a504c644110644d0ad45b8f1d7d8e344d4.tar.gz
Pull the latest kryoflux-ui.jar (until a new Linux release is done)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--kryoflux.sh2
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 125e31fadd66..287be5f87dec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kryoflux
pkgdesc = USB Floppy Controller for Software Preservation
pkgver = 2.6
- pkgrel = 5
+ pkgrel = 6
url = http://www.kryoflux.com
install = kryoflux.install
arch = i686
@@ -10,19 +10,21 @@ pkgbase = kryoflux
makedepends = gendesk
makedepends = imagemagick
depends = libusb
- optdepends = jre7-openjdk: for the Kryoflux GUI
+ optdepends = java-runtime: for the Kryoflux GUI
optdepends = archlinux-java-run: for the Kryoflux GUI
provides = capsimage
conflicts = capsimage
source = http://www.kryoflux.com/download/kryoflux_2.6_linux.tar.bz2
+ source = https://kryoflux.com/kryoflux-ui.jar
source = 80-kryoflux.rules
source = kryoflux.conf
source = kryoflux.sh
source = https://webstore.kryoflux.com/catalog/images/kf_logo_big.png
md5sums = 12d57dcc9657a90c583dded553b8a2e1
+ md5sums = 44a067aa8d40dd0c8c53d6ff3ad8109c
md5sums = 43ec7eb49fbdab703cafe146145fe0de
md5sums = ede10c48b2b1edc5c346e8814f07bcdb
- md5sums = e5f6e87858ba2172a1530f3826539caa
+ md5sums = 6811dc57633d7046a540b65e763aa338
md5sums = ede9a2b77643af8bf9d166c30827c170
pkgname = kryoflux
diff --git a/PKGBUILD b/PKGBUILD
index 0295ac2aebdd..70074e0784af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=kryoflux
pkgdesc="USB Floppy Controller for Software Preservation"
pkgver=2.6
-pkgrel=5
+pkgrel=6
arch=('i686' 'x86_64')
url="http://www.kryoflux.com"
license=('custom')
@@ -13,16 +13,18 @@ conflicts=('capsimage')
depends=('libusb')
install=kryoflux.install
makedepends=('gendesk' 'imagemagick')
-optdepends=('jre7-openjdk: for the Kryoflux GUI' 'archlinux-java-run: for the Kryoflux GUI')
+optdepends=('java-runtime: for the Kryoflux GUI' 'archlinux-java-run: for the Kryoflux GUI')
source=("http://www.kryoflux.com/download/kryoflux_${pkgver}_linux.tar.bz2"
+ 'https://kryoflux.com/kryoflux-ui.jar'
'80-kryoflux.rules'
'kryoflux.conf'
'kryoflux.sh'
'https://webstore.kryoflux.com/catalog/images/kf_logo_big.png')
md5sums=('12d57dcc9657a90c583dded553b8a2e1'
+ '44a067aa8d40dd0c8c53d6ff3ad8109c'
'43ec7eb49fbdab703cafe146145fe0de'
'ede10c48b2b1edc5c346e8814f07bcdb'
- 'e5f6e87858ba2172a1530f3826539caa'
+ '6811dc57633d7046a540b65e763aa338'
'ede9a2b77643af8bf9d166c30827c170')
prepare() {
@@ -45,7 +47,8 @@ package() {
# rename dtc binary to kdtc to avoid clash with dtc package (suggested by @frankspace)
install dtc/${CARCH}/static/dtc ${pkgroot}/bin/kdtc
install -Dm755 dtc/${CARCH}/static/dtc ${pkgroot}/share/java/kryoflux/dtc
- install -Dm644 dtc/kryoflux-ui.jar ${pkgroot}/share/java/kryoflux/kryoflux-ui.jar
+ # install -Dm644 dtc/kryoflux-ui.jar ${pkgroot}/share/java/kryoflux/kryoflux-ui.jar
+ install -Dm644 ${srcdir}/kryoflux-ui.jar ${pkgroot}/share/java/kryoflux/kryoflux-ui.jar
cp -P dtc/${CARCH}/lib* ${pkgroot}/lib
# Firmwares: choose one or the other
diff --git a/kryoflux.sh b/kryoflux.sh
index faf28579b1bd..6d9930de8f84 100644
--- a/kryoflux.sh
+++ b/kryoflux.sh
@@ -1,3 +1,3 @@
#!/bin/sh
export PATH=/usr/share/java/kryoflux:$PATH
-archlinux-java-run --max 8 -- -jar /usr/share/java/kryoflux/kryoflux-ui.jar
+java -jar /usr/share/java/kryoflux/kryoflux-ui.jar "$@"