summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorreplydev2023-02-11 17:32:55 +0100
committerreplydev2023-02-11 17:32:55 +0100
commite8fabb400f79b22d4173ea9278e34c8847f43bab (patch)
tree0352f4a9c1f3b79962750adb051b9f1e3e27c513
downloadaur-e8fabb400f79b22d4173ea9278e34c8847f43bab.tar.gz
Initial PKGBUILD for kryptor-bin package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a7ab55689f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kryptor-bin
+ pkgdesc = A simple, modern, and secure encryption and signing tool that aims to be a better version of age and Minisign.
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = https://www.kryptor.co.uk/
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ provides = kryptor
+ conflicts = kryptor
+ options = !strip
+ source_x86_64 = https://github.com/samuel-lucas6/Kryptor/releases/download/v4.0.1/kryptor-linux-x64.zip
+ sha512sums_x86_64 = d517a7e38220eb0a8a2937768ca85b660c10224b0ddc64a509f8e3b81f9db04162de6f2316ee38acce6839f9ad140f53013100f7a76bc25b79ae310d0c75e3f3
+ source_aarch64 = https://github.com/samuel-lucas6/Kryptor/releases/download/v4.0.1/kryptor-linux-arm64.zip
+ sha512sums_aarch64 = 549b44059e4074a4f7bba27a7b94fe74e2785f87c59fd9cbbe4feedd0ecc88478323960499e0a862ddcb5e82a1d9fa324101b06024cb5259d71c3bd9c6a6d408
+
+pkgname = kryptor-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..413b834b502b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: replydev <commoncargo@tutanota.com>
+
+pkgname=kryptor-bin
+pkgver=4.0.1
+pkgrel=1
+pkgdesc='A simple, modern, and secure encryption and signing tool that aims to be a better version of age and Minisign.'
+arch=('x86_64' 'aarch64')
+url='https://www.kryptor.co.uk/'
+license=('GPL3')
+source_x86_64=("https://github.com/samuel-lucas6/Kryptor/releases/download/v$pkgver/kryptor-linux-x64.zip")
+source_aarch64=("https://github.com/samuel-lucas6/Kryptor/releases/download/v$pkgver/kryptor-linux-arm64.zip")
+sha512sums_x86_64=('d517a7e38220eb0a8a2937768ca85b660c10224b0ddc64a509f8e3b81f9db04162de6f2316ee38acce6839f9ad140f53013100f7a76bc25b79ae310d0c75e3f3')
+sha512sums_aarch64=('549b44059e4074a4f7bba27a7b94fe74e2785f87c59fd9cbbe4feedd0ecc88478323960499e0a862ddcb5e82a1d9fa324101b06024cb5259d71c3bd9c6a6d408')
+conflicts=('kryptor')
+provides=('kryptor')
+# Important to disable binary strip, otherwise the artifact would be corrupted
+options=(!strip)
+
+package() {
+ cd "$srcdir/"
+ install -Dm755 "${srcdir}/kryptor" "${pkgdir}/usr/bin/kryptor"
+}