summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPawel Dzieciolowski2017-08-18 01:14:36 +0200
committerPawel Dzieciolowski2017-08-18 01:14:36 +0200
commitc67b49cbc317ec974b44e570a63aa65cf063befc (patch)
tree0a7ceaeeff926b602cf2d45bc5c601d671889ac6
downloadaur-c67b49cbc317ec974b44e570a63aa65cf063befc.tar.gz
Initial submission
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5da26e336ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kscript
+ pkgdesc = Enhanced scripting support for Kotlin on *nix-based systems
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/holgerbrandl/kscript
+ arch = any
+ license = custom
+ depends = kotlin
+ source = https://raw.githubusercontent.com/holgerbrandl/kscript/v1.6.0/kscript
+ source = https://raw.githubusercontent.com/holgerbrandl/kscript/v1.6.0/README.md
+ source = https://raw.githubusercontent.com/holgerbrandl/kscript/v1.6.0/LICENSE.txt
+ sha256sums = fb43043a60be53f3d8e3cf93d173fb9119c87e9ba89e3b0cdb02029826149ccc
+ sha256sums = d1c0c387aa6f3781da1c84b567637fe889374068cb1efa838b1568d8e9570846
+ sha256sums = 9f17c220a84297bff2720e11849ab0eacfdb564f5e6b7f1e1d768619787bf2d9
+
+pkgname = kscript
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..286c808191a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Pawel Dzieciolowski <dzieciolowski dot pawel at gmail com>
+
+pkgname=kscript
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='Enhanced scripting support for Kotlin on *nix-based systems'
+arch=('any')
+url='https://github.com/holgerbrandl/kscript'
+license=('custom')
+depends=('kotlin')
+_source_url="https://raw.githubusercontent.com/holgerbrandl/${pkgname}/v${pkgver}"
+source=("${_source_url}/kscript" "${_source_url}/README.md" "${_source_url}/LICENSE.txt")
+sha256sums=('fb43043a60be53f3d8e3cf93d173fb9119c87e9ba89e3b0cdb02029826149ccc'
+ 'd1c0c387aa6f3781da1c84b567637fe889374068cb1efa838b1568d8e9570846'
+ '9f17c220a84297bff2720e11849ab0eacfdb564f5e6b7f1e1d768619787bf2d9')
+
+package() {
+ cd "${srcdir}"
+
+ install -Dm 755 kscript "${pkgdir}/usr/bin/kscript"
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm 644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}