summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2021-11-05 23:09:28 +0100
committerml2021-11-05 23:28:24 +0100
commiteb704a79f2d64deecf505b1a94158da149e13a93 (patch)
tree66b3fbc4392681d74d5346432c02b858c0d853d9
parent7d026ba71c40609da15c6e20d4feb83fc1976764 (diff)
downloadaur-ksd.tar.gz
updpkg: ksd 1.0.7-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f28c2bbc0917..2e13b5f5e76b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ksd
pkgdesc = kubernetes secret decoder
- pkgver = 1.0.6
- pkgrel = 2
+ pkgver = 1.0.7
+ pkgrel = 1
url = https://github.com/mfuentesg/ksd
arch = x86_64
arch = i686
+ arch = aarch64
license = MIT
makedepends = go
depends = glibc
- source = ksd-1.0.6.tar.gz::https://github.com/mfuentesg/ksd/archive/v1.0.6.tar.gz
- sha256sums = 90d1b0bc68de22b2acf7f24f53aaa6756cecb4122dd646949118c2d9bcd7eed0
+ source = https://github.com/mfuentesg/ksd/archive/v1.0.7/ksd-1.0.7.tar.gz
+ sha256sums = 4cff240a64807c454b6b5b4bf08bee69fb6d5a6117fa28fb7c4d0ef534f1855a
pkgname = ksd
-
diff --git a/PKGBUILD b/PKGBUILD
index 2be02de9b52a..14246965d10e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
-# Maintainer: ml <ml@visu.li>
+# Maintainer: ml <>
pkgname=ksd
-pkgver=1.0.6
-pkgrel=2
+pkgver=1.0.7
+pkgrel=1
pkgdesc='kubernetes secret decoder'
-arch=('x86_64' 'i686')
+arch=('x86_64' 'i686' 'aarch64')
url='https://github.com/mfuentesg/ksd'
license=('MIT')
depends=('glibc')
makedepends=('go')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('90d1b0bc68de22b2acf7f24f53aaa6756cecb4122dd646949118c2d9bcd7eed0')
+source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('4cff240a64807c454b6b5b4bf08bee69fb6d5a6117fa28fb7c4d0ef534f1855a')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
export CGO_ENABLED=1
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
- export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
- go build -o "$pkgname" -ldflags="-linkmode=external -X main.version=v${pkgver}"
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw'
+ go build -o "$pkgname" -ldflags="-linkmode=external -X=main.version=v$pkgver" main.go
}
check() {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
go test
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 -t "${pkgdir}/usr/bin" "$pkgname"
- install -Dm755 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ cd "$pkgname-$pkgver"
+ install -Dm755 -t "$pkgdir/usr/bin" "$pkgname"
+ install -Dm755 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}