summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2017-11-30 19:51:01 -0500
committerChris Severance2017-11-30 19:51:01 -0500
commitbfc7f4697e907f6e9be50ab8d3ecabcbbf7f3892 (patch)
treefbb3591144b894d5e1ec7be43426cf423f23432c
parent34f5b91260f859104bedd67cdbcd7e7f8cf18b88 (diff)
downloadaur-ksh.tar.gz
bz1477082.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--bz1477082.patch38
3 files changed, 48 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5457dfcbda02..767514bb1a97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Jan 19 17:00:17 UTC 2016
+# Fri Dec 1 00:50:27 UTC 2017
pkgbase = ksh
pkgdesc = AT&T's Korn shell ksh93 nmake from ast-base
pkgver = 2014.06.25beta
@@ -17,9 +17,11 @@ pkgbase = ksh
source = INIT.2014-12-24.tgz::https://github.com/nathanmkaya/ksh-arch/blob/master/INIT.2014-12-24.tgz?raw=true
source = ast-base.2014-06-25.tgz::https://github.com/nathanmkaya/ksh-arch/blob/master/ast-base.2014-06-25.tgz?raw=true
source = http://http.us.debian.org/debian/pool/main/k/ksh/ksh_93u+20120801-1_amd64.deb
+ source = bz1477082.patch
sha256sums = 8852b9d37d5034e3780aeb5f963726381eeb4e08bb5bee1fbfa7e3f529c10e1b
sha256sums = 58588b07b076f05dbbd5f4f095d5753309a8356ba1e5475262ce77d6bff42dae
sha256sums = 37495cc625a2174b22a43542acac1d69402ee4992ee084a84690546c5b932b39
+ sha256sums = 9cfd9a549ed8913e9edc98a6e596c441d2538f145f8c4711ad3d46ce79fa104e
pkgname = ksh
diff --git a/PKGBUILD b/PKGBUILD
index 3c98d1f16809..3b85da6df33f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -108,7 +108,8 @@ source[1]="ast-base.2014-06-25.tgz::https://github.com/nathanmkaya/ksh-arch/blob
# :; is to keep updpkgsums from removing all our sums
:;sha256sums=('8852b9d37d5034e3780aeb5f963726381eeb4e08bb5bee1fbfa7e3f529c10e1b'
'58588b07b076f05dbbd5f4f095d5753309a8356ba1e5475262ce77d6bff42dae'
- '37495cc625a2174b22a43542acac1d69402ee4992ee084a84690546c5b932b39')
+ '37495cc625a2174b22a43542acac1d69402ee4992ee084a84690546c5b932b39'
+ '9cfd9a549ed8913e9edc98a6e596c441d2538f145f8c4711ad3d46ce79fa104e')
else
pkgver='2012.08.01'
pkgrel='5'
@@ -120,9 +121,11 @@ source=("http://${_opt_EPLUSERE}:${_opt_EPLPASS}@www2.research.att.com/~astopen/
source[1]="http://download.openpkg.org/components/cache/nmake/ast-base.2012-08-01.tgz"
:;sha256sums=('8852b9d37d5034e3780aeb5f963726381eeb4e08bb5bee1fbfa7e3f529c10e1b'
'3bd668dbd922790f1d24c78e3522ef4816501e9cf80abf3c480f554c74f4dbac'
- '37495cc625a2174b22a43542acac1d69402ee4992ee084a84690546c5b932b39')
+ '37495cc625a2174b22a43542acac1d69402ee4992ee084a84690546c5b932b39'
+ '9cfd9a549ed8913e9edc98a6e596c441d2538f145f8c4711ad3d46ce79fa104e')
fi
source[0]="INIT.2014-12-24.tgz::https://github.com/nathanmkaya/ksh-arch/blob/master/INIT.2014-12-24.tgz?raw=true"
+source+=('bz1477082.patch') # https://github.com/att/ast/pull/63 https://bugzilla.redhat.com/show_bug.cgi?id=1477082
# makepkg unpacking deb files into the src folder isn't particularly useful.
noextract=("${_debfile}")
@@ -236,6 +239,8 @@ prepare() {
# https://forums.opensuse.org/showthread.php/508185-GCC-5/page2
# https://build.opensuse.org/package/view_file/home:Andreas_Schwab:Factory/ksh/cpp.patch?expand=1
sed -i -e 's:$cc -E:$cc -E -P:g' 'src/cmd/INIT/iffe.sh'
+
+ patch -Nbup1 -i "${srcdir}/bz1477082.patch"
set +u
}
diff --git a/bz1477082.patch b/bz1477082.patch
new file mode 100644
index 000000000000..28be43bf083b
--- /dev/null
+++ b/bz1477082.patch
@@ -0,0 +1,38 @@
+diff --git a/src/lib/libast/features/stdio b/src/lib/libast/features/stdio
+--- a/src/lib/libast/features/stdio
++++ b/src/lib/libast/features/stdio
+@@ -6,6 +6,8 @@ cat{
+ #define _FILE_DEFINED 1
+ #define _FILE_defined 1
+ #define _FILEDEFED 1
++ #define __FILE_defined 1
++ #define ____FILE_defined 1
+
+ #ifndef __FILE_TAG
+ #define __FILE_TAG _sfio_s
+diff --git a/src/lib/libast/include/ast.h b/src/lib/libast/include/ast.h
+index ebf82d7..f4bbe6d 100644
+--- a/src/lib/libast/include/ast.h
++++ b/src/lib/libast/include/ast.h
+@@ -59,9 +59,21 @@ struct _sfio_s;
+ #ifndef __FILE_typedef
+ #define __FILE_typedef 1
+ #endif
++#ifndef _FILE_DEFINED
++#define _FILE_DEFINED 1
++#endif
++#ifndef _FILE_defined
++#define _FILE_defined 1
++#endif
+ #ifndef _FILEDEFED
+ #define _FILEDEFED 1
+ #endif
++#ifndef __FILE_defined
++#define __FILE_defined 1
++#endif
++#ifndef ____FILE_defined
++#define ____FILE_defined 1
++#endif
+ #endif
+
+ /*