summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohnothan King2024-02-09 16:00:14 -0800
committerJohnothan King2024-02-09 16:00:20 -0800
commit471b62ccc727165a69a4e57226daa6dc486a2c55 (patch)
treefb1aa8e5dd3ada5c9cd5ee2dd5c2ed02f77526d9
parentf1591cd17a8beb5f22a4d6e371ad8485c6b33934 (diff)
downloadaur-471b62ccc727165a69a4e57226daa6dc486a2c55.tar.gz
Fix build after changing flags in makepkg.conf
If the build flags in makepkg.conf change after the previous build, the bin/package script will force the build to fail. Delete the build directory beforehand to prevent this scenario.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3e9e70eeabd..3c3ea9a57ef8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ksh93-git
pkgdesc = KornShell 93u+m, fork based on ksh 93u+
- pkgver = r1546.e63febac
+ pkgver = r1578.5948b420
pkgrel = 1
url = https://github.com/ksh93/ksh/
install = ksh93.install
diff --git a/PKGBUILD b/PKGBUILD
index 9a4533475273..303bd608fe76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname='ksh93'
pkgname="${_pkgname}-git"
-pkgver=r1546.e63febac
+pkgver=r1578.5948b420
pkgrel=1
pkgdesc="KornShell 93u+m, fork based on ksh 93u+"
arch=('x86_64')
@@ -36,7 +36,8 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
- test -n "${CFLAGS}" || CFLAGS=-O2 # Generic fallback is used only when necessary
+ test -n "${CFLAGS}" || CFLAGS=-O2 # This generic fallback is only used when necessary.
+ rm -rf ./arch # Get rid of any leftover build files, in case the flags in makepkg.conf changed.
./bin/package make CCFLAGS="${CFLAGS}"
}