summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2015-10-27 19:28:06 +0000
committerScore_Under2015-10-27 19:28:06 +0000
commit66348c745668eeeac5709deab25e9e8ddcb235da (patch)
treeb2812bc5485172c9c443efaeca58bb633075803f
parent14259cf22b2897e34cbd3b2df2c6a9032ea9692e (diff)
downloadaur-66348c745668eeeac5709deab25e9e8ddcb235da.tar.gz
Fix mistyped path in ksm-wrapper
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xksm-wrapper5
3 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbd426361c3d..5394fc0156bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = ksm_preload-git
source = git+https://github.com/unbrice/ksm_preload.git
source = ksm-wrapper
sha256sums = SKIP
- sha256sums = c58dd36fd3a58d4e94da75472b3dd864ce865bb35e23fb422abda446ddc4afc4
+ sha256sums = 348c6c707eef3f6efed5896492faa6482ad8fe964a0eab8eec8fec1217069610
pkgname = ksm_preload-git
diff --git a/PKGBUILD b/PKGBUILD
index 97c90630c382..a0186172c722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ source=("git+https://github.com/unbrice/$_pkgname.git"
ksm-wrapper)
optdepends=('sh: ksm-wrapper script')
sha256sums=('SKIP'
- 'c58dd36fd3a58d4e94da75472b3dd864ce865bb35e23fb422abda446ddc4afc4')
+ '348c6c707eef3f6efed5896492faa6482ad8fe964a0eab8eec8fec1217069610')
cdgit() { cd -- "$_pkgname"; }
diff --git a/ksm-wrapper b/ksm-wrapper
index 6535f4945115..f5618c2cabc1 100755
--- a/ksm-wrapper
+++ b/ksm-wrapper
@@ -1,8 +1,9 @@
#!/bin/sh
# Rewrite of ksm-wrapper to work in /usr/bin
+sofile=libksm_preload.so
case " $LD_PRELOAD " in
- (*" ksm_preload.so "*) ;;
- (*) LD_PRELOAD="${LD_PRELOAD:+$LD_PRELOAD }ksm_preload.so"
+ (*" $sofile "*) ;;
+ (*) LD_PRELOAD="${LD_PRELOAD:+$LD_PRELOAD }$sofile"
export LD_PRELOAD;;
esac
exec "$@"