summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2019-11-25 09:51:02 +0530
committerlibrewish2019-11-25 09:51:02 +0530
commit77381a444e75dbe81e84f9b36acf9e8a23063a39 (patch)
tree2e6103006e5f07d2d1280b994a3e4deb254fe247
downloadaur-77381a444e75dbe81e84f9b36acf9e8a23063a39.tar.gz
update
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eae568f0e769
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ksmoothdock-git
+ pkgdesc = A cool desktop panel for KDE Plasma 5
+ pkgver = r550.793b94e
+ pkgrel = 1
+ url = https://github.com/dangvd/ksmoothdock
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = python
+ depends = kactivities
+ depends = kxmlgui
+ source = git+https://github.com/dangvd/ksmoothdock
+ sha256sums = SKIP
+
+pkgname = ksmoothdock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f90b27ab19a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: librewish <librewish at gmail dot com>
+
+
+pkgname=ksmoothdock-git
+pkgver=r550.793b94e
+pkgrel=1
+pkgdesc='A cool desktop panel for KDE Plasma 5'
+arch=(any)
+url='https://github.com/dangvd/ksmoothdock'
+license=('GPL3')
+depends=('kactivities' 'kxmlgui')
+makedepends=('cmake' 'extra-cmake-modules' 'python')
+source=("git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ksmoothdock"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd ${srcdir}/ksmoothdock
+
+ cmake src \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+
+ make
+
+ }
+
+package() {
+ make -C ${srcdir}/ksmoothdock DESTDIR="$pkgdir" install
+}