summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Werner Rau2020-11-26 20:41:07 +0100
committerChris Werner Rau2020-11-26 20:41:07 +0100
commit11d64ba24a25c14ac3265f3f1d654f7de98b3c05 (patch)
tree2691730a9d8372c53d9b6d1e7a0849e450148923
parent5e7024ba94e304e2b23bf6c4bf49349e15870df7 (diff)
downloadaur-11d64ba24a25c14ac3265f3f1d654f7de98b3c05.tar.gz
Add pinniped package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD92
2 files changed, 21 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b8024e9c67..45bf65b580a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
-pkgbase = pkgbase
- pkgdesc = Japanese-Russian kanji and word dictionary
- pkgver = 1.10
+pkgbase = pinniped-bin
+ pkgdesc = Pinniped provides identity services for Kubernetes clusters
+ pkgver = 0.2.0
pkgrel = 1
- url = http://www.susi.ru/yarxi/
+ url = https://github.com/vmware-tanzu/pinniped
arch = x86_64
- license = custom
- depends = ttf-sazanami
- depends = nas
+ license = APACHE
+ conflicts = pinniped
+ conflicts = pinniped-git
+ source = pinniped::https://github.com/vmware-tanzu/pinniped/releases/download/v0.2.0/pinniped-cli-linux-amd64
+ sha512sums = 1d940739bdab3b01bab32c8b5982891003b1e78e5de0eb1906d51cd61a41bb5d72925871cf6161fd4f0130d61e8cbab0067dc9a7e1aead0a4cc44e2997a8f324
-pkgname = yarxi
+pkgname = pinniped-bin
diff --git a/PKGBUILD b/PKGBUILD
index e21a86c2f396..9b46dc1e2cbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,89 +1,19 @@
-# Maintainer Seva Alekseyev <sevaa@yarxi.ru>
-# Maintainer Stoyan Minaev <stoyan.minaev@gmail.com>
+# Maintainer Chris Werner Rau <aur@cwrau.io>
-pkgbase=pkgbase
-pkgname=yarxi
-pkgver=1.10
+_pkgname=pinniped
+pkgname=$_pkgname-bin
+pkgver=0.2.0
pkgrel=1
-pkgdesc="Japanese-Russian kanji and word dictionary"
-url="http://www.susi.ru/yarxi/"
-license=('custom')
-_source=(
- "http://www.susi.ru/yarxi/yarxi_${pkgver}-${pkgrel}_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqtcore4_4.8.7+dfsg-11_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqtgui4_4.8.7+dfsg-11_amd64.deb"
- "http://ftp.uk.debian.org/debian/pool/main/q/qt4-x11/libqt4-network_4.8.7+dfsg-11_amd64.deb"
-)
+pkgdesc="Pinniped provides identity services for Kubernetes clusters"
+url="https://github.com/vmware-tanzu/$_pkgname"
+license=('APACHE')
+source=("$_pkgname::$url/releases/download/v$pkgver/$_pkgname-cli-linux-amd64")
arch=('x86_64')
-_md5sums=(
- '812d2265816ed781751c5c0eb6664d91'
- 'b243ada8569b2b3d4586dc4178fd8d56'
- '797e351a57c9d56368f710e7cba40f21'
- 'b3cff12767e21d3a76794046557d3df0'
-)
-depends=(
- ttf-sazanami nas
-)
-
-prepare() {
- cd $srcdir/
- echo "Due to 'makepkg' and 'PKGBUILD' specs limitations I need to dowanload sources and validate them by myself"
- for source_url in ${_source[@]}; do
- source_filename=${source_url##*/}
- if [ ! -f "$source_filename" ]; then
- echo "Downloading next source - $source_filename ..."
- curl -A DUMMY -O "$source_url";
- else
- echo "Found already downloaded source - $source_filename"
- fi
- done
- echo "And now we must validated dowanloaded sources ..."
- for (( i=0; i<${#_source[@]}; ++i )); do
- source_url=${_source[i]}
- source_filename=${source_url##*/}
- source_expected_md5sum=${_md5sums[i]}
- source_actual_md5sum=$(md5sum $source_filename | awk '{print $1}')
- if [ "$source_actual_md5sum" == "$source_expected_md5sum" ]; then
- echo "Validated next source - $source_filename"
- else
- echo "Found corrupted source - $source_filename"; return 1
- fi
- done
-}
-
-build() {
- cd $srcdir/
- mkdir -p deb/{$pkgname,qt4core,qt4gui,qt4network}
- bsdtar xf yarxi_${pkgver}-${pkgrel}_amd64.deb -C deb/$pkgname/
- bsdtar xf libqtcore4_4.8.7+dfsg-11_amd64.deb -C deb/qt4core/
- bsdtar xf libqtgui4_4.8.7+dfsg-11_amd64.deb -C deb/qt4gui/
- bsdtar xf libqt4-network_4.8.7+dfsg-11_amd64.deb -C deb/qt4network/
- for dir in deb/$pkgname deb/qt4core deb/qt4gui deb/qt4network; do
- cd $dir; tar xf data.tar.*; cd $srcdir
- done
-}
+sha512sums=('1d940739bdab3b01bab32c8b5982891003b1e78e5de0eb1906d51cd61a41bb5d72925871cf6161fd4f0130d61e8cbab0067dc9a7e1aead0a4cc44e2997a8f324')
+conflicts=("$_pkgname" "${_pkgname}-git")
package() {
- cd $srcdir/
- mkdir -p $pkgdir/usr/lib/
- mkdir -p $pkgdir/usr/bin/
- mkdir -p $pkgdir/usr/share/
- mkdir -p $pkgdir/usr/share/applications/
- mkdir -p $pkgdir/usr/share/doc/$pkgname/
- mkdir -p $pkgdir/usr/share/icons/hicolor/{16x16/apps,32x32/apps,48x48/apps}/
- mkdir -p $pkgdir/usr/share/pixmaps/
- mkdir -p $pkgdir/usr/share/$pkgname/
- install -m 0755 $srcdir/deb/$pkgname/usr/bin/$pkgname $pkgdir/usr/bin/$pkgname
- install -m 0755 $srcdir/deb/qt4core/usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.7 $pkgdir/usr/lib/libQtCore.so.4
- install -m 0755 $srcdir/deb/qt4gui/usr/lib/x86_64-linux-gnu/libQtGui.so.4.8.7 $pkgdir/usr/lib/libQtGui.so.4
- install -m 0755 $srcdir/deb/qt4network/usr/lib/x86_64-linux-gnu/libQtNetwork.so.4.8.7 $pkgdir/usr/lib/libQtNetwork.so.4
- install -m 0644 $srcdir/deb/$pkgname/usr/share/applications/seva-yarxi.desktop $pkgdir/usr/share/applications/
- install -m 0644 $srcdir/deb/$pkgname/usr/share/doc/$pkgname/copyright $pkgdir/usr/share/doc/$pkgname/
- for icons in 16x16 32x32 48x48; do
- install -m 0644 $srcdir/deb/$pkgname/usr/share/icons/hicolor/$icons/apps/seva-yarxi.png $pkgdir/usr/share/icons/hicolor/$icons/apps/
- done
- install -m 0644 $srcdir/deb/$pkgname/usr/share/pixmaps/*.xpm $pkgdir/usr/share/pixmaps/
- install -m 0644 $srcdir/deb/$pkgname/usr/share/$pkgname/yarxice.db $pkgdir/usr/share/$pkgname/
+ install -D -m 0755 $srcdir/$_pkgname $pkgdir/usr/bin/$_pkgname
}
#vim: syntax=sh