summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalkut2020-11-05 12:25:54 -0500
committerMalkut2020-11-05 12:25:54 -0500
commit646d801796dc6ee3151613093e563074e1a6d22f (patch)
tree8e88e706104695ef6fb3f9f2138db4453d0a3493
parent03f579d8e799fd4fa4704cc9a656bb4cca04a08d (diff)
downloadaur-646d801796dc6ee3151613093e563074e1a6d22f.tar.gz
Updated git source, patch. Note that HDF5 Api changes breaks compatibilty for versions > 1.12
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fixed-HDF5-patch-for-archlinux-users.patch14
-rw-r--r--PKGBUILD8
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 019dd395135c..381ed2f0580f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,10 +18,10 @@ pkgbase = kst-git
optdepends = getdata: provides support for files in the Dirfile format
optdepends = libmatio: provides support for Matlab binary files
conflicts = kst
- source = git://anongit.kde.org/kst-plot.git
+ source = https://invent.kde.org/graphics/kst-plot.git
source = 0001-Fixed-HDF5-patch-for-archlinux-users.patch
md5sums = SKIP
- md5sums = 775b873a12b1b6125bd02cad752a9306
+ md5sums = bcb70f7257da37e57938879ebfbd7466
pkgname = kst-git
diff --git a/0001-Fixed-HDF5-patch-for-archlinux-users.patch b/0001-Fixed-HDF5-patch-for-archlinux-users.patch
index 402acf9e2512..b53902a40ed0 100644
--- a/0001-Fixed-HDF5-patch-for-archlinux-users.patch
+++ b/0001-Fixed-HDF5-patch-for-archlinux-users.patch
@@ -20,6 +20,20 @@ index 03bdd792..7d5a4961 100644
#include <exception>
#include "debug.h"
+
+diff --git a/src/widgets/gradienteditor.h b/src/widgets/gradienteditor.h
+index 1ca74922..67c3d089 100644
+--- a/src/widgets/gradienteditor.h
++++ b/src/widgets/gradienteditor.h
+@@ -16,5 +16,6 @@
+ #include <QHash>
+ #include <QWidget>
+ #include <QGradient>
++#include <QPainterPath>
+
+ #include "kstwidgets_export.h"
+
+
--
2.22.0
diff --git a/PKGBUILD b/PKGBUILD
index 6a5f70ce0370..30bca53146b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
_pkgname="kst"
pkgname="${_pkgname}-git"
pkgrel=1
-pkgver=2.0.8r3383.8294c2fe
+pkgver=2.0.8r3411.b2e8bcf8
pkgdesc="Fast real-time large-dataset viewing and plotting tool for KDE"
arch=('i686' 'x86_64')
url="http://kst-plot.kde.org"
license=('GPL')
-depends=('hdf5' 'gsl' 'qt5-base' 'qt5-svg' 'muparser' 'python2-scipy>=0.9' 'python2-numpy>=1.6' 'cfitsio' 'python2-pyside')
+depends=('hdf5<1.12.0' 'gsl' 'qt5-base' 'qt5-svg' 'muparser' 'python2-scipy>=0.9' 'python2-numpy>=1.6' 'cfitsio' 'python2-pyside')
optdepends=(
'getdata: provides support for files in the Dirfile format'
'libmatio: provides support for Matlab binary files'
)
makedepends=('cmake')
#install=$pkgname.install
-source=("git://anongit.kde.org/kst-plot.git" "0001-Fixed-HDF5-patch-for-archlinux-users.patch")
-md5sums=('SKIP' '775b873a12b1b6125bd02cad752a9306')
+source=("git+https://invent.kde.org/graphics/kst-plot.git" "0001-Fixed-HDF5-patch-for-archlinux-users.patch")
+md5sums=('SKIP' 'bcb70f7257da37e57938879ebfbd7466')
provides=("${_pkgname}")
pkgver() {
cd "${srcdir}/${_pkgname}-plot"