summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Menard2021-10-24 18:15:38 +0000
committerNicolas Menard2021-10-24 18:15:38 +0000
commit71c692daba624457de2e36698dd5d227d510cde7 (patch)
tree102c2ca4f45b9375fcf6ae8b976a467178f60af8
parent2842b4d8b36ff786c6e550713828276acaa9ac24 (diff)
downloadaur-71c692daba624457de2e36698dd5d227d510cde7.tar.gz
Fixed compile issue and locked HDF5 to a version pre 1.12.1
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fixed-HDF5-patch-for-archlinux-users.patch13
-rw-r--r--PKGBUILD6
3 files changed, 5 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c5918603586..3ab7d0d22cb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = kst-git
arch = x86_64
license = GPL
makedepends = cmake
- depends = hdf5
+ depends = hdf5<1.12.1
depends = gsl
depends = qt5-base
depends = muparser
@@ -21,7 +21,7 @@ pkgbase = kst-git
source = https://invent.kde.org/graphics/kst-plot.git
source = 0001-Fixed-HDF5-patch-for-archlinux-users.patch
md5sums = SKIP
- md5sums = bcb70f7257da37e57938879ebfbd7466
+ md5sums = 4913f0bdccfa8adba09f6b6bf5bb2d11
pkgname = kst-git
diff --git a/0001-Fixed-HDF5-patch-for-archlinux-users.patch b/0001-Fixed-HDF5-patch-for-archlinux-users.patch
index b53902a40ed0..5a3f6e44fa91 100644
--- a/0001-Fixed-HDF5-patch-for-archlinux-users.patch
+++ b/0001-Fixed-HDF5-patch-for-archlinux-users.patch
@@ -21,19 +21,6 @@ index 03bdd792..7d5a4961 100644
#include "debug.h"
-diff --git a/src/widgets/gradienteditor.h b/src/widgets/gradienteditor.h
-index 1ca74922..67c3d089 100644
---- a/src/widgets/gradienteditor.h
-+++ b/src/widgets/gradienteditor.h
-@@ -16,5 +16,6 @@
- #include <QHash>
- #include <QWidget>
- #include <QGradient>
-+#include <QPainterPath>
-
- #include "kstwidgets_export.h"
-
-
--
2.22.0
diff --git a/PKGBUILD b/PKGBUILD
index 25aa04cd3ca6..9e8baa9fb793 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
_pkgname="kst"
pkgname="${_pkgname}-git"
pkgrel=1
-pkgver=2.0.8r3416.6e92ce01
+pkgver=2.0.8r3428.606588ce
pkgdesc="Fast real-time large-dataset viewing and plotting tool for KDE"
arch=('i686' 'x86_64')
url="http://kst-plot.kde.org"
license=('GPL')
-depends=('hdf5' 'gsl' 'qt5-base' 'qt5-svg' 'muparser' 'python-scipy>=0.9' 'python-numpy>=1.6' 'cfitsio' 'python-pyside2')
+depends=('hdf5<1.12.1' 'gsl' 'qt5-base' 'qt5-svg' 'muparser' 'python-scipy>=0.9' 'python-numpy>=1.6' 'cfitsio' 'python-pyside2')
optdepends=(
'getdata: provides support for files in the Dirfile format'
'libmatio: provides support for Matlab binary files'
@@ -14,7 +14,7 @@ optdepends=(
makedepends=('cmake')
#install=$pkgname.install
source=("git+https://invent.kde.org/graphics/kst-plot.git" "0001-Fixed-HDF5-patch-for-archlinux-users.patch")
-md5sums=('SKIP' 'bcb70f7257da37e57938879ebfbd7466')
+md5sums=('SKIP' '4913f0bdccfa8adba09f6b6bf5bb2d11')
provides=("${_pkgname}")
pkgver() {
cd "${srcdir}/${_pkgname}-plot"