summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalkut2015-09-28 09:58:30 -0400
committerMalkut2015-09-28 10:04:12 -0400
commit79674fc7c2ed6f26e902bb7620ac0665ab8fb9d7 (patch)
tree41a05bf2eacc3a597f74d9ad3dc8ec1aac540ac2
parent2c71704fe9e7515877d11c37337f4a12ce539419 (diff)
downloadaur-79674fc7c2ed6f26e902bb7620ac0665ab8fb9d7.tar.gz
Fixed build process and netcdf-legacy
-rw-r--r--0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch26
-rw-r--r--PKGBUILD10
2 files changed, 33 insertions, 3 deletions
diff --git a/0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch b/0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch
new file mode 100644
index 000000000000..48daf230e768
--- /dev/null
+++ b/0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch
@@ -0,0 +1,26 @@
+From 671d22f4c5bd5f971907e13e6b90d4d4ed63f8f8 Mon Sep 17 00:00:00 2001
+From: Nicolas Menard <nicolas.menard@wyss.harvard.edu>
+Date: Mon, 28 Sep 2015 09:42:20 -0400
+Subject: [PATCH] Fixed compilation error for ambiguous overload off abs in
+ curve.cpp
+
+---
+ src/libkstmath/curve.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libkstmath/curve.cpp b/src/libkstmath/curve.cpp
+index dc61ae1..ffe0ee6 100644
+--- a/src/libkstmath/curve.cpp
++++ b/src/libkstmath/curve.cpp
+@@ -36,7 +36,7 @@
+
+ #include <time.h>
+ #include <iostream>
+-
++#include <cmath>
+ // #define DEBUG_VECTOR_CURVE
+ // #define BENCHMARK
+
+--
+2.5.3
+
diff --git a/PKGBUILD b/PKGBUILD
index d57fbe7cba1a..2827773adf82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@ pkgdesc="Fast real-time large-dataset viewing and plotting tool for KDE"
arch=('i686' 'x86_64')
url="http://kst-plot.kde.org"
license=('GPL')
-depends=('gsl' 'qt4' 'muparser' 'python2-scipy>=0.9' 'python2-numpy>=1.6' 'cfitsio' 'netcdf-cxx-legacy' 'python2-pyside')
+depends=('gsl' 'qt4' 'muparser' 'python2-scipy>=0.9' 'python2-numpy>=1.6' 'cfitsio' 'python2-pyside')
optdepends=(
'getdata: provides support for files in the Dirfile format'
'libmatio: provides support for Matlab binary files'
)
makedepends=('cmake')
#install=$pkgname.install
-source=("git://github.com/Kst-plot/kst.git")
-md5sums=('SKIP')
+source=("git://github.com/Kst-plot/kst.git" "0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch")
+md5sums=('SKIP' '43dad5d63cf1d3415a5dda3df2e02c08')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -33,6 +33,10 @@ build() {
-Dkst_python_prefix=/usr/lib/python2.7 \
-Dkst_install_prefix=/usr/
}
+prepare(){
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 < ../0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch
+}
package() {
cd "${srcdir}/${_pkgname}"
make -j$(nproc) DESTDIR="${pkgdir}" install