summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalkut2016-02-04 16:50:32 -0500
committerMalkut2016-02-04 16:50:32 -0500
commitaa9074a94c30ffd76002c0098553d7f6ff947ad8 (patch)
tree7753daed6f858cede9630d4196a690422eb77d13
parent0cf330991168b490c19cc25e12b2823e117131e9 (diff)
downloadaur-aa9074a94c30ffd76002c0098553d7f6ff947ad8.tar.gz
fixed pkgver issue and fixed an install issue where cmake was trying to copy svg file instead of svgz
-rw-r--r--0001-fixed-issue-where-src-kst-CMakeLists.txt-was-referri.patch33
-rw-r--r--PKGBUILD18
2 files changed, 43 insertions, 8 deletions
diff --git a/0001-fixed-issue-where-src-kst-CMakeLists.txt-was-referri.patch b/0001-fixed-issue-where-src-kst-CMakeLists.txt-was-referri.patch
new file mode 100644
index 000000000000..e4ab8512543c
--- /dev/null
+++ b/0001-fixed-issue-where-src-kst-CMakeLists.txt-was-referri.patch
@@ -0,0 +1,33 @@
+From d83e68f80a93e4823a7e303ea1fac4f5a4e9a848 Mon Sep 17 00:00:00 2001
+From: Nicolas Menard <nicolas.menard@wyss.harvard.edu>
+Date: Thu, 4 Feb 2016 15:02:09 -0500
+Subject: [PATCH 1/1] fixed issue where src/kst/CMakeLists.txt was referring to
+ kst.svg and not kst.svgz
+
+---
+ src/kst/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/kst/CMakeLists.txt b/src/kst/CMakeLists.txt
+index dc333e8..e7c1e5e 100644
+--- a/src/kst/CMakeLists.txt
++++ b/src/kst/CMakeLists.txt
+@@ -58,13 +58,13 @@ if(UNIX AND NOT APPLE)
+ install(FILES ${kst_dir}/src/images/48x48/kst.png DESTINATION share/icons/hicolor/48x48/apps)
+ install(FILES ${kst_dir}/src/images/64x64/kst.png DESTINATION share/icons/hicolor/64x64/apps)
+ install(FILES ${kst_dir}/src/images/128x128/kst.png DESTINATION share/icons/hicolor/128x128/apps)
+- install(FILES ${kst_dir}/src/images/svg_icons/kst.svg DESTINATION share/icons/hicolor/scalable/apps)
++ install(FILES ${kst_dir}/src/images/svg_icons/kst.svgz DESTINATION share/icons/hicolor/scalable/apps)
+
+ install(FILES ${kst_dir}/src/images/32x32/application-x-kst.png DESTINATION share/icons/hicolor/32x32/apps)
+ install(FILES ${kst_dir}/src/images/48x48/application-x-kst.png DESTINATION share/icons/hicolor/48x48/apps)
+ install(FILES ${kst_dir}/src/images/64x64/application-x-kst.png DESTINATION share/icons/hicolor/64x64/apps)
+ install(FILES ${kst_dir}/src/images/128x128/application-x-kst.png DESTINATION share/icons/hicolor/128x128/apps)
+- install(FILES ${kst_dir}/src/images/svg_icons/application-x-kst.svg DESTINATION share/icons/hicolor/scalable/apps)
++ install(FILES ${kst_dir}/src/images/svg_icons/application-x-kst.svgz DESTINATION share/icons/hicolor/scalable/apps)
+
+ endif()
+
+--
+2.7.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 2827773adf82..dce52ca66230 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
_pkgname="kst"
pkgname="${_pkgname}-git"
pkgrel=1
-pkgver=2.0.8
+pkgver=2.0.8r3108.084d3ad
pkgdesc="Fast real-time large-dataset viewing and plotting tool for KDE"
arch=('i686' 'x86_64')
url="http://kst-plot.kde.org"
license=('GPL')
-depends=('gsl' 'qt4' 'muparser' 'python2-scipy>=0.9' 'python2-numpy>=1.6' 'cfitsio' 'python2-pyside')
+depends=('gsl' 'qt5-base' 'muparser' 'python2-scipy>=0.9' 'python2-numpy>=1.6' 'cfitsio' 'python2-pyside')
optdepends=(
'getdata: provides support for files in the Dirfile format'
'libmatio: provides support for Matlab binary files'
)
makedepends=('cmake')
#install=$pkgname.install
-source=("git://github.com/Kst-plot/kst.git" "0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch")
-md5sums=('SKIP' '43dad5d63cf1d3415a5dda3df2e02c08')
+source=("git://github.com/Kst-plot/kst.git" "0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch" "0001-fixed-issue-where-src-kst-CMakeLists.txt-was-referri.patch")
+md5sums=('SKIP' '43dad5d63cf1d3415a5dda3df2e02c08' '7e908388bf2127b499fb2f60c1e9907f')
pkgver() {
cd "${srcdir}/${_pkgname}"
- 2.0.8-$(git describe --long --always | sed -r 's/([^-]*-g)/r\1/;s/-/./g')
+ printf "2.0.8r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
conflicts=("kst")
build() {
@@ -26,16 +26,18 @@ build() {
cp -r ./cmake/pyKst/* ./pyKst/
cmake ./ \
-Dkst_release=2 \
- -Dkst_version_string=$(pkgver) \
+ -Dkst_version_string=2.0.8 \
-Dkst_svnversion=0 \
-Dkst_python=1 \
-DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
-Dkst_python_prefix=/usr/lib/python2.7 \
- -Dkst_install_prefix=/usr/
+ -Dkst_install_prefix=/usr \
+ -Dkst_qt5=ON
}
prepare(){
cd "${srcdir}/${_pkgname}"
- patch -p1 < ../0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch
+ patch -p1 < ../0001-Fixed-compilation-error-for-ambiguous-overload-off-a.patch
+ patch -p1 < ../0001-fixed-issue-where-src-kst-CMakeLists.txt-was-referri.patch
}
package() {
cd "${srcdir}/${_pkgname}"