summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalkut2018-06-21 10:36:38 -0400
committerMalkut2018-06-21 10:36:38 -0400
commitb9139b80778975897d74c3f16ba585e046115fa6 (patch)
tree394361cc34e4ea594f1b579c993d8fcd44a8b59a
parent812480814ae2988dc2092099cf9cc72815043043 (diff)
downloadaur-b9139b80778975897d74c3f16ba585e046115fa6.tar.gz
Fixed build issue for QT5 based on net147 comment
-rw-r--r--0001-Build-fixes-for-Qt-5.11.patch39
-rw-r--r--PKGBUILD7
2 files changed, 43 insertions, 3 deletions
diff --git a/0001-Build-fixes-for-Qt-5.11.patch b/0001-Build-fixes-for-Qt-5.11.patch
new file mode 100644
index 000000000000..7547deffd920
--- /dev/null
+++ b/0001-Build-fixes-for-Qt-5.11.patch
@@ -0,0 +1,39 @@
+From edeb0d979991966b5fc5ee901c9f06065e08a3bc Mon Sep 17 00:00:00 2001
+From: Nicolas Menard <nicolas.menard@wyss.harvard.edu>
+Date: Thu, 21 Jun 2018 09:13:55 -0400
+Subject: [PATCH] Build fixes for Qt 5.11
+
+---
+ cmake/modules/KstMacros.cmake | 2 +-
+ src/libkstapp/view.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/modules/KstMacros.cmake b/cmake/modules/KstMacros.cmake
+index 676d5731..d340185f 100644
+--- a/cmake/modules/KstMacros.cmake
++++ b/cmake/modules/KstMacros.cmake
+@@ -240,7 +240,7 @@ endmacro()
+ macro(kst_link)
+ target_link_libraries(${kst_name} ${ARGV})
+ if(kst_qt5)
+- qt5_use_modules(${kst_name} Widgets Xml Network PrintSupport Svg)
++ target_link_libraries(${kst_name} Qt5::Widgets Qt5::Xml Qt5::Network Qt5::PrintSupport Qt5::Svg)
+ else()
+ target_link_libraries(${kst_name}
+ ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTSVG_LIBRARY} ${QT_QTNETWORK_LIBRARY})
+diff --git a/src/libkstapp/view.h b/src/libkstapp/view.h
+index 95c8c6a5..607991b7 100644
+--- a/src/libkstapp/view.h
++++ b/src/libkstapp/view.h
+@@ -19,7 +19,7 @@
+
+ #include "curveplacement.h"
+
+-
++class QMenu;
+ class QUndoStack;
+ class QXmlStreamWriter;
+
+--
+2.17.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 699dae145358..61607fc20e7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgname="kst"
pkgname="${_pkgname}-git"
pkgrel=1
-pkgver=2.0.8r3268.540a599a
+pkgver=2.0.8r3342.39b8a6c3
pkgdesc="Fast real-time large-dataset viewing and plotting tool for KDE"
arch=('i686' 'x86_64')
url="http://kst-plot.kde.org"
@@ -13,8 +13,8 @@ optdepends=(
)
makedepends=('cmake')
#install=$pkgname.install
-source=("git://github.com/Kst-plot/kst.git")
-md5sums=('SKIP' )
+source=("git://github.com/Kst-plot/kst.git" "0001-Build-fixes-for-Qt-5.11.patch")
+md5sums=('SKIP' '755de805f90f6e76eddd1f5f59d86a98')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -36,6 +36,7 @@ build() {
}
prepare(){
cd "${srcdir}/${_pkgname}"
+ patch -p1 < ../0001-Build-fixes-for-Qt-5.11.patch
}
package() {
cd "${srcdir}/${_pkgname}"