summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalkut2018-10-03 09:38:34 -0400
committerMalkut2018-10-03 09:38:34 -0400
commitef87ca55904fd6c5bfdcee280c50dc006aabc1ef (patch)
treea251a57ba75a43fddf9e2cd317b2db82ded89b55
parent798cbd04963fbe1339007f69844c4a0e2d73a58c (diff)
downloadaur-ef87ca55904fd6c5bfdcee280c50dc006aabc1ef.tar.gz
Removed qt5_use_module patch
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Build-fixes-for-Qt-5.11.patch24
-rw-r--r--PKGBUILD6
3 files changed, 9 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d321ebdb939..6bf4c2fdcb6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,7 +20,7 @@ pkgbase = kst-git
source = git://github.com/Kst-plot/kst.git
source = 0001-Build-fixes-for-Qt-5.11.patch
md5sums = SKIP
- md5sums = 755de805f90f6e76eddd1f5f59d86a98
+ md5sums = b655a89d78c7dc80f7692f5c218e05dc
pkgname = kst-git
diff --git a/0001-Build-fixes-for-Qt-5.11.patch b/0001-Build-fixes-for-Qt-5.11.patch
index 7547deffd920..1f37597576eb 100644
--- a/0001-Build-fixes-for-Qt-5.11.patch
+++ b/0001-Build-fixes-for-Qt-5.11.patch
@@ -1,26 +1,12 @@
-From edeb0d979991966b5fc5ee901c9f06065e08a3bc Mon Sep 17 00:00:00 2001
+From 74f022c09d25fbdcf8373bd5a255d7408ef60801 Mon Sep 17 00:00:00 2001
From: Nicolas Menard <nicolas.menard@wyss.harvard.edu>
-Date: Thu, 21 Jun 2018 09:13:55 -0400
+Date: Wed, 3 Oct 2018 09:14:36 -0400
Subject: [PATCH] Build fixes for Qt 5.11
---
- cmake/modules/KstMacros.cmake | 2 +-
- src/libkstapp/view.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
+ src/libkstapp/view.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/cmake/modules/KstMacros.cmake b/cmake/modules/KstMacros.cmake
-index 676d5731..d340185f 100644
---- a/cmake/modules/KstMacros.cmake
-+++ b/cmake/modules/KstMacros.cmake
-@@ -240,7 +240,7 @@ endmacro()
- macro(kst_link)
- target_link_libraries(${kst_name} ${ARGV})
- if(kst_qt5)
-- qt5_use_modules(${kst_name} Widgets Xml Network PrintSupport Svg)
-+ target_link_libraries(${kst_name} Qt5::Widgets Qt5::Xml Qt5::Network Qt5::PrintSupport Qt5::Svg)
- else()
- target_link_libraries(${kst_name}
- ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTSVG_LIBRARY} ${QT_QTNETWORK_LIBRARY})
diff --git a/src/libkstapp/view.h b/src/libkstapp/view.h
index 95c8c6a5..607991b7 100644
--- a/src/libkstapp/view.h
@@ -35,5 +21,5 @@ index 95c8c6a5..607991b7 100644
class QXmlStreamWriter;
--
-2.17.1
+2.19.0
diff --git a/PKGBUILD b/PKGBUILD
index 6ae27b3ea517..09525e93df0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_pkgname="kst"
pkgname="${_pkgname}-git"
pkgrel=1
-pkgver=2.0.8r3342.39b8a6c3
+pkgver=2.0.8r3357.9db9477d
pkgdesc="Fast real-time large-dataset viewing and plotting tool for KDE"
arch=('i686' 'x86_64')
url="http://kst-plot.kde.org"
@@ -14,7 +14,7 @@ optdepends=(
makedepends=('cmake')
#install=$pkgname.install
source=("git://github.com/Kst-plot/kst.git" "0001-Build-fixes-for-Qt-5.11.patch")
-md5sums=('SKIP' '755de805f90f6e76eddd1f5f59d86a98')
+md5sums=('SKIP' 'b655a89d78c7dc80f7692f5c218e05dc')
pkgver() {
cd "${srcdir}/${_pkgname}"
printf "2.0.8r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -41,4 +41,4 @@ package() {
cd "${srcdir}/${_pkgname}"
make -j$(nproc) DESTDIR="${pkgdir}" install
install -D -m644 "COPYING" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
-} \ No newline at end of file
+}