summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlestofante2020-04-04 20:45:28 +0200
committerlestofante2020-04-04 20:45:28 +0200
commit203a974622f174cae68b805bf4bd3953eb78e757 (patch)
tree5ddcf772514a42d210a7ee88cdda4284c37630b6
downloadaur-203a974622f174cae68b805bf4bd3953eb78e757.tar.gz
first versin
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45dc0d09386e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ksysguard-gpu
+ pkgdesc = gpu visualization for ksysguard
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://github.com/lestofante/ksysguard-gpu
+ arch = any
+ license = GPL3
+ depends = python
+ optdepends = ksysguard: For connecting to script as intended
+ optdepends = radeontop: AMD card support
+ optdepends = intel-gpu-tools: Intel card support
+ optdepends = nvidia-utils: NVIDIA card support
+ source = ksysguard-gpu-0.5-1.tar.gz::https://github.com/lestofante/ksysguard-gpu/archive/0.5.tar.gz
+ sha256sums = 266cdb212c1861699f7815c4d10f7b7fa75292cbd8e2c0425f184ef46b0bf75d
+
+pkgname = ksysguard-gpu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..917ca3e5a0b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: lesto <lestofante88@gmail.com>
+
+pkgname=ksysguard-gpu
+pkgver=0.5
+pkgrel=1
+pkgdesc="gpu visualization for ksysguard"
+arch=(any)
+url="https://github.com/lestofante/ksysguard-gpu"
+license=('GPL3')
+depends=('python')
+optdepends=('ksysguard: For connecting to script as intended'
+ 'radeontop: AMD card support'
+ 'intel-gpu-tools: Intel card support'
+ 'nvidia-utils: NVIDIA card support')
+source=("${pkgname}-${pkgver}-${pkgrel}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('266cdb212c1861699f7815c4d10f7b7fa75292cbd8e2c0425f184ef46b0bf75d')
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}/"
+ mkdir -p "${pkgdir}/usr/lib/systemd/system/"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm644 "systemd-unit/ksysguard-gpu.service" "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm755 "src/ksysguard-gpu.py" "${pkgdir}/usr/bin/"
+}