summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBob Durand2017-05-05 22:12:51 -0400
committerBob Durand2017-05-05 22:12:51 -0400
commit2a791fe3261886c1d74a86d0d5f4522be6f6678c (patch)
tree2ff490497e19e938dce52147987b387e8b14064a
downloadaur-2a791fe3261886c1d74a86d0d5f4522be6f6678c.tar.gz
Initial commit of the ktechlab software. I am not the original developper of the package, and I do not intend to do copyright infrigment, but the package seems to be released under GPL
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rwxr-xr-xktechlab-git.desktop14
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd9675e36ebd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ktechlab-git
+ pkgdesc = KTechLab is an IDE for microcontrollers and electronics. It supports circuit simulation, program development for microcontrollers and simulating the programmed microcontroller together with its application circuit.
+ pkgver = 0.3.7.r1747d071
+ pkgrel = 2
+ url = https://github.com/ktechlab/ktechlab
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = gendesk
+ depends = qt4
+ source = git+https://github.com/ktechlab/ktechlab
+ source = ktechlab-git.desktop
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = ktechlab-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3624c0beabd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: dmidge <quelque_ri1 at caramail point fr>
+pkgname=ktechlab-git
+pkgver=0.3.7.r1747d071
+pkgrel=2
+pkgdesc="KTechLab is an IDE for microcontrollers and electronics. It supports circuit simulation, program development for microcontrollers and simulating the programmed microcontroller together with its application circuit."
+arch=('x86_64' 'i686')
+url="https://github.com/ktechlab/ktechlab"
+license=('GPL')
+#options=(!makeflags)
+depends=('qt4')
+makedepends=('git' 'cmake' 'gcc' 'gendesk')
+source=(git+https://github.com/ktechlab/ktechlab
+ "$pkgname.desktop")
+md5sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd ktechlab
+ echo "0.3.7.r`git describe --always`"
+}
+
+#prepare() {
+# gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
+#}
+
+build() {
+ cd ktechlab
+ if [ ! -d build ]; then
+ mkdir build
+ fi
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=debugfull
+ make
+}
+
+package() {
+ cd $srcdir/ktechlab/build
+ make DESTDIR="$pkgdir" install
+ install -d $pkgdir/usr/share/pixmaps
+ install -m664 $srcdir/ktechlab/icons/hi128-app-ktechlab.png $pkgdir/usr/share/pixmaps/$pkgname-icon.png
+}
diff --git a/ktechlab-git.desktop b/ktechlab-git.desktop
new file mode 100755
index 000000000000..ca919df21745
--- /dev/null
+++ b/ktechlab-git.desktop
@@ -0,0 +1,14 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Name=Ktechlab
+Comment=Design an electronic circuit
+Comment[fr]=Concevoir un circuit électronique
+GenericName=Ktechlab
+Icon=ktechlab-git-icon
+Type=Application
+Categories=Development;Electronics;
+Encoding=UTF-8
+Exec=ktechlab
+Terminal=false
+MultipleArgs=false
+StartupNotify=true