summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-10-27 01:16:01 +0200
committersL1pKn072023-10-27 01:18:08 +0200
commit428c751f47dbe23a3e09691070ae115ce8318f47 (patch)
tree039817a673ade35c9a85e9d6eff9329842e88e9b
parent98af754035f0e6898b52dcba443da625b215b527 (diff)
downloadaur-428c751f47dbe23a3e09691070ae115ce8318f47.tar.gz
bump
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD78
-rwxr-xr-xktechlab-git.desktop14
4 files changed, 81 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab82de78ba9f..a88aa1191485 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,35 @@
pkgbase = ktechlab-git
- pkgdesc = KTechLab is an IDE for microcontrollers and electronics. It supports circuit simulation, program development for microcontrollers and simulating the programmed microcontroller together with its application circuit.
- pkgver = 0.3.7.r1747d071
- pkgrel = 3
+ pkgdesc = KTechLab is an IDE for microcontrollers and electronics. It supports circuit simulation, program development for microcontrollers and simulating the programmed microcontroller together with its application circuit. (GIT version)
+ pkgver = 0.51.0.13.g7a62f7fd
+ pkgrel = 1
url = https://github.com/ktechlab/ktechlab
arch = x86_64
- arch = i686
license = GPL
makedepends = git
makedepends = cmake
- makedepends = gcc
- makedepends = gendesk
- depends = qt4
- source = git+https://github.com/ktechlab/ktechlab
- source = ktechlab-git.desktop
- md5sums = SKIP
- md5sums = SKIP
+ makedepends = qt5-tools
+ depends = gcc-libs
+ depends = glibc
+ depends = kcompletion5
+ depends = kconfig5
+ depends = kconfigwidgets5
+ depends = kcoreaddons5
+ depends = ki18n5
+ depends = kiconthemes5
+ depends = kio5
+ depends = kjobwidgets5
+ depends = kparts5
+ depends = ktexteditor5
+ depends = ktextwidgets5
+ depends = kwidgetsaddons5
+ depends = kwindowsystem5
+ depends = kxmlgui5
+ depends = qt5-base
+ depends = qt5-serialport
+ depends = gpsim
+ depends = hicolor-icon-theme
+ options = debug
+ source = git+https://github.com/ktechlab/ktechlab.git
+ sha256sums = SKIP
pkgname = ktechlab-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 8f7ac67d73dd..b5a85d1bbe13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,63 @@
-# Maintainer: dmidge <quelque_ri1 at caramail point fr>
+# Contributor: dmidge <quelque_ri1 at caramail point fr>
+
pkgname=ktechlab-git
-pkgver=0.3.7.rv0.40.0.r8.g34b41aa3
-pkgrel=3
-pkgdesc="KTechLab is an IDE for microcontrollers and electronics. It supports circuit simulation, program development for microcontrollers and simulating the programmed microcontroller together with its application circuit."
-arch=('x86_64' 'i686')
+pkgver=0.51.0.13.g7a62f7fd
+pkgrel=1
+pkgdesc="KTechLab is an IDE for microcontrollers and electronics. It supports circuit simulation, program development for microcontrollers and simulating the programmed microcontroller together with its application circuit. (GIT version)"
+arch=('x86_64')
url="https://github.com/ktechlab/ktechlab"
license=('GPL')
-#options=(!makeflags)
-depends=('qt4' 'kdelibs')
-makedepends=('git' 'cmake' 'gcc' 'gendesk' 'automoc4')
-source=(git+https://github.com/ktechlab/ktechlab
- "$pkgname.desktop")
-md5sums=('SKIP'
- 'SKIP')
+depends=(
+ 'gcc-libs' # libstdc++.so
+ 'glibc' # libc.so libm.so
+ 'kcompletion5' # libKF5Completion.so
+ 'kconfig5' # libKF5ConfigCore.so libKF5ConfigGui.so
+ 'kconfigwidgets5' # libKF5ConfigWidgets.so
+ 'kcoreaddons5' # libKF5CoreAddons.so
+ 'ki18n5' # libKF5I18n.so
+ 'kiconthemes5' # libKF5IconThemes.so
+ 'kio5' # libKF5KIOCore.so libKF5KIOWidgets.so
+ 'kjobwidgets5' # libKF5JobWidgets.so
+ 'kparts5' # libKF5Parts.so
+ 'ktexteditor5' # libKF5TextEditor.so
+ 'ktextwidgets5' # libKF5TextWidgets.so
+ 'kwidgetsaddons5' # libKF5WidgetsAddons.so
+ 'kwindowsystem5' # libKF5WindowSystem.so
+ 'kxmlgui5' # libKF5XmlGui.so
+ 'qt5-base' # libQt5Core.so libQt5Gui.so libQt5PrintSupport.so libQt5Widgets.so libQt5Xml.so
+ 'qt5-serialport' # libQt5SerialPort.so
+ 'gpsim' # libgpsim.so
+ 'hicolor-icon-theme'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'qt5-tools'
+)
+source=('git+https://github.com/ktechlab/ktechlab.git')
+sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd ktechlab
- echo "0.3.7.r`git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'`"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
-#prepare() {
-# gendesk -n --pkgname "$pkgname" --pkgdesc "$pkgdesc"
-#}
-
build() {
- cd ktechlab
- if [ ! -d build ]; then
- mkdir build
- fi
+
+ cmake -S ktechlab -B build \
+ -DCMAKE_BUILD_TYPE=none \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTING=ON
+
+ cmake --build build
+}
+
+check() {
cd build
- cmake .. -DCMAKE_BUILD_TYPE=debugfull
- make
+ ctest --output-on-failure
}
package() {
- cd $srcdir/ktechlab/build
- make DESTDIR="$pkgdir" install
- install -d $pkgdir/usr/share/pixmaps
- install -m664 $srcdir/ktechlab/icons/hi128-app-ktechlab.png $pkgdir/usr/share/pixmaps/$pkgname-icon.png
-}
+ DESTDIR="${pkgdir}" cmake --install build
+}
diff --git a/ktechlab-git.desktop b/ktechlab-git.desktop
deleted file mode 100755
index ca919df21745..000000000000
--- a/ktechlab-git.desktop
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/usr/bin/env xdg-open
-[Desktop Entry]
-Name=Ktechlab
-Comment=Design an electronic circuit
-Comment[fr]=Concevoir un circuit électronique
-GenericName=Ktechlab
-Icon=ktechlab-git-icon
-Type=Application
-Categories=Development;Electronics;
-Encoding=UTF-8
-Exec=ktechlab
-Terminal=false
-MultipleArgs=false
-StartupNotify=true