summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 22:47:26 +0200
committerAntonio Rojas2015-06-08 22:47:26 +0200
commit48376ab41f9bd54599eaa00e81a2354c146998bc (patch)
tree700e9db2a78c03660356c1e8fa6a1457de53c015
downloadaur-48376ab41f9bd54599eaa00e81a2354c146998bc.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
-rw-r--r--pkgbuild-syntax-highlight.patch11
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ec4ed5ce192
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ktexteditor-git
+ pkgdesc = KTextEditor framework
+ pkgver = r807.d13bfd1
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/ktexteditor
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules-git
+ makedepends = git
+ depends = kparts-git
+ depends = libgit2
+ provides = ktexteditor
+ conflicts = ktexteditor
+ source = git://anongit.kde.org/ktexteditor.git
+ source = pkgbuild-syntax-highlight.patch
+ md5sums = SKIP
+ md5sums = cc66f75c967dd7ac7c97375875772d69
+
+pkgname = ktexteditor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b856f80473e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=ktexteditor-git
+pkgver=r807.d13bfd1
+pkgrel=1
+pkgdesc='KTextEditor framework'
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/frameworks/ktexteditor'
+license=('LGPL')
+depends=('kparts-git' 'libgit2')
+makedepends=('extra-cmake-modules-git' 'git')
+provides=('ktexteditor')
+conflicts=('ktexteditor')
+source=('git://anongit.kde.org/ktexteditor.git' "pkgbuild-syntax-highlight.patch")
+md5sums=('SKIP'
+ 'cc66f75c967dd7ac7c97375875772d69')
+
+pkgver() {
+ cd ktexteditor
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+ cd ktexteditor
+ patch -p0 -i $srcdir/pkgbuild-syntax-highlight.patch
+}
+
+build() {
+ cd build
+ cmake ../ktexteditor \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DBUILD_TESTING=OFF \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/pkgbuild-syntax-highlight.patch b/pkgbuild-syntax-highlight.patch
new file mode 100644
index 000000000000..bcecc7e52acd
--- /dev/null
+++ b/pkgbuild-syntax-highlight.patch
@@ -0,0 +1,11 @@
+--- src/syntax/data/bash.xml~ 2013-06-13 09:46:51.569245577 +0000
++++ src/syntax/data/bash.xml 2013-06-13 09:47:31.745637790 +0000
+@@ -8,7 +8,7 @@
+ <!ENTITY noword "(?![\w$+-])"> <!-- no word, $, + or - following -->
+ <!ENTITY pathpart "([\w_@.&#37;*?+-]|\\ )"> <!-- valid character in a file name -->
+ ]>
+-<language name="Bash" version="2.17" kateversion="2.4" section="Scripts" extensions="*.sh;*.bash;*.ebuild;*.eclass;.bashrc;.bash_profile;.bash_login;.profile" mimetype="application/x-shellscript" casesensitive="1" author="Wilbert Berendsen (wilbert@kde.nl)" license="LGPL">
++<language name="Bash" version="2.17" kateversion="2.4" section="Scripts" extensions="*.sh;*.bash;*.ebuild;*.eclass;.bashrc;.bash_profile;.bash_login;.profile;PKGBUILD" mimetype="application/x-shellscript" casesensitive="1" author="Wilbert Berendsen (wilbert@kde.nl)" license="LGPL">
+
+ <!-- (c) 2004 by Wilbert Berendsen (wilbert@kde.nl)
+ Changes by Matthew Woehlke (mw_triad@users.sourceforge.net)