summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrançois Boulogne2018-04-26 11:30:13 +0200
committerFrançois Boulogne2018-04-26 11:30:13 +0200
commit5bc15fafc660ee73e7e536d1aa545cc6bef151da (patch)
tree0db457d32a37f8a0e4b00203eb43689461e6b0d5
parent3370459e77a1092e269d1b89f37ea4f7b095b74e (diff)
downloadaur-5bc15fafc660ee73e7e536d1aa545cc6bef151da.tar.gz
various fixes
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccea18d394ab..dae16773ff29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
pkgname=ktikz
pkgver=0.12
-pkgrel=1
+pkgrel=2
pkgdesc="A small application helping you to create TikZ diagrams (from the LaTeX pgf package)"
arch=('i686' 'x86_64')
url="http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language/"
license=('GPL')
depends=('poppler-qt5' 'kdebase-runtime')
-makedepends=('cmake' 'docbook-xml')
+makedepends=('cmake' 'docbook-xml' 'qt5-tools')
source=("https://github.com/fhackenberger/ktikz/archive/$pkgver.tar.gz")
md5sums=('3834a2c0c7d135eb7f958053a56c07ca')
build() {
cd $pkgname-$pkgver
- mkdir buildqt
+ mkdir -p buildqt
cd buildqt
qmake ../qtikz.pro
make
@@ -22,6 +22,7 @@ package() {
cd $pkgname-$pkgver
cd buildqt
make INSTALL_ROOT="$pkgdir" install
- ln -s "$pkgdir"/usr/bin/qtikz "$pkgdir"/usr/bin/ktikz
+ cd $pkgdir/usr/bin
+ ln -sf qtikz ktikz
}